Bug 29126 - mouse misdetection
mouse misdetection
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 14:18 EST by Jeff Lane
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 22:15:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Lane 2001-02-23 14:18:34 EST
I have three different kickstart installs that i have tried.  The one
english one works, the two foreign lang ones fail.  

After install completes, on reboot, I get the hideous gpm was mysteriously
murdered error:

According to /var/run/gdm.pid, gdm was already running (812), but seems to
have been murdered mysteriously.

This is immediately after a fresh ks install via NFS .

I am thinking that this may be due to the X not being set up properly.  
At boot, I get the framebuffer invalid mode message.  Then on examining
XF86Config, it seems that my Viewsonic g773 monitor was not probed, and was
listed incorrectly.  
 For some reason, the installer, in these ks installs decided to install
the framebuffer instead...  This is probably more to do with my scripts
than anything else, but may be the cause of this problem.

Also, the mouse, a generic 2 button mouse, was listed as a 3 button ps2
with ZAxis Mapping turned on.

After booting to single, I had to change the password (the password was not
set correctly by kickstart)

then I had to run Xconfigurator to reconfig the video, which properly gave
me X functionality.

and the screen blanks after about 60  seconds instead of the typical 5
minutes.
I also had to change inittab from defaulting to 5 to defaulting to 3 to
avoid the gdm issue.
Here are my three ks.cfg files, all three were created with ksconfig:

English -----
#Generated by Kickstart Configurator
lang en_US
keyboard us
mouse generic3ps/2
timezone --utc America/New_York
rootpw fortlewis 
nfs --server porkchop --dir /mnt/test/wolverine/i386
network --bootproto dhcp
install
auth --useshadow --enablemd5firewall --high --trust eth0 --ftp --ssh --dhcp
--ht
tp 
zerombr yes
clearpart --all
part /boot  --size 35
part swap --size 128
part /  --size 1000 --grow
lilo --location mbr
%packages 
@Everything


Russian------

#Generated by Kickstart Configurator
lang ru_RU.K0I8-R
keyboard us
mouse generic3ps/2
timezone --utc America/New_York
rootpw fortlewis 
nfs --server porkchop --dir /mnt/test/wolverine/i386
network --bootproto dhcp
install
auth --useshadow --enablemd5
zerombr yes
part /boot  --size 35
part swap --size 128
part /  --size 1000 --grow
lilo --location mbr
%Packages
@Workstation

Spanish------

#Generated by Kickstart Configurator
lang es_ES
keyboard us
mouse generic2ps/2
timezone --utc Asia/Tokyo
rootpw fortlewis
nfs --server porkchop --dir /mnt/test/wolverine/i386
network --bootproto dhcp
install
auth --useshadow --enablemd5firewall --disabled 
zerombr yes
clearpart --all
part /boot  --size 35
part swap --size 128
part /  --size 1000 --grow
lilo --location mbr
%packages 
@Everything
Comment 1 Glen Foster 2001-02-23 16:54:28 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Mike A. Harris 2001-02-25 09:18:07 EST
Can you replicate this problem without using kickstart?  If not, then it
must be an installer related issue.  Please try without kickstart.  If it
does fail still, please include your Xserver logs and XF86config-4 as
attachments.
Comment 3 Mike A. Harris 2001-03-14 02:15:10 EST
After looking at your problem some more it seems much more likely that
your mouse is misconfigured.  Please read the XFree86 mouse manpage,
and try out the various mouse types listed until you find one that works.
Rerun mouseconfig, Xconfigurator and change the mouse type accordingly:

man -a mouse

Try different settings, and if one works, please change the bug to
"Xconfigurator" or kudzu so Preston/Bill can look into it.  I
don't think this is particularly an XFree86 issue, but more one of install
time autodetection, etc.
Comment 4 Mike A. Harris 2001-03-18 23:17:14 EST
Reassigning to mouseconfig in case that is relevant.  I don't see it as an X
bug because X just uses the mouse driver it is told to.
Comment 5 Jeff Lane 2001-03-19 08:53:03 EST
Actually, I was thinking more along the lines of having one language and a
different keymap... but that was just the only variables that I could find. 
Either way in the three ks scripts, in the English one, the mouse is listed as
generic3ps/2, same in the Russian one.  in the Spanish one, the mouse is listed
as generic2ps/2 which is closer to the truth.

either way, every time I try an install, the default is always a 3 button ps/2,
almost as if no probing is done to determine.  This has happened with several
mice, and as a matter of fact, as far as probing goes, I have tried three
different versions of MS and Logitech wheelmice, a generic IBM 2 button, and a
couple generic three button PS/2 mice, and ALL of them are detected as generic 3
button PS/2 mice.  

so... I will try again with a different kscfg file and we shall see what
happens...
Comment 6 Bill Nottingham 2001-03-19 22:15:15 EST
All PS2 mice are more or less equal, as far as the probing is concerned.

Note You need to log in before you can comment on or make changes to this bug.