Bug 291381 - Upgrade failed from FC-6 with anaconda/rpmdb error
Upgrade failed from FC-6 with anaconda/rpmdb error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 14:09 EDT by Denis Leroy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 13:33:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2007-09-14 14:09:50 EDT
While trying to upgrade my old Thinkpad T30 from FC-6 to F8-test2, the graphical
installer gets stuck with the message "829 of 828 packages installed". Mouse
cursor is moving, but process is otherwise stuck.

Going to console screen 1, i'm seeing scrolling messages :

rpmdb: PANIC: fatal region error detected: run recovery


In console screen 3, I have:

19:22:04 INFO : Preparing to install packages
19:36:54 WARNING : /usr/lib/anaconda/iw/progress_gui.py:55: GtkWarning: Failed
to set text from markup due to error parsing markup: Error on line 2: Character
'' is not valid at the start of an entity name; the & character begins an
entity; if this ampersand isn't supposed to be an entity, escape it as &
  self.infolabel.set_markup(txt)

19:37:11 WARNING: /usr/lib/anaconda/iw/progress_gui.py:49: GtkWarning:
gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0` failed
  self.progress.set_fraction(pct)

This is on a Thinkpad T30 (i386), running FC-6. Upgrade done through network PXE.
Comment 1 Denis Leroy 2007-09-20 13:33:59 EDT
Looks like i had a broken rpm database. After rebuilding the database, the
upgrade went fine. Well, the installer completed the upgrade. Now the kernel
crashes on boot, but that's another story...

Note You need to log in before you can comment on or make changes to this bug.