Bug 29154 - Launching KDM freezes the system
Summary: Launching KDM freezes the system
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 23:14 UTC by Joe Morris
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 05:53:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Morris 2001-02-23 23:14:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


When launching KDM login manager, the screen goes crazy and the system 
locks up.

Reproducible: Always
Steps to Reproduce:
1. Edit settings in /etc/inittab and set default runlevel to 3.
2. Reboot and login.
3. Type "kdm" at the prompt.
	

Actual Results:  X begins to start, but then the screen gets distorted 
(like vertical colored lines) and the system locks up.

Expected Results:  The KDE login manager should have appeared.

My system has an S3 Savage4 card w/32 MB memory. I have never had this 
problem in RedHat 7. I login as usual, but upon typing 'kdm', the X starts 
to load and the system hangs. Typing 'gdm' works okay. I don't know if 
this is a KDE bug or what. I know one thing, XF86 4.0.2 doesn't like my 
card very well (I can't have a high resolution and I can only get 16 bit 
colors. In XF86 3.3.6, I could get as high a resolution as wanted with up 
to 32 bit colors. Perhaps you could change this and make using 4.0.2 
optional during the setup??? I would really appreciate that!).  I can load 
KDE with no problems from GDM, I just can't launch KDM. I have had no 
other X or KDE related prolems. Well, thank you guys again!
Joe

Comment 1 Joe Morris 2001-02-24 00:05:58 UTC
By the way, my system is a PIII 500MHz with 128 MB of RAM.

Comment 2 Glen Foster 2001-02-26 22:49:19 UTC
Can you reproduce this behavior with Wolverine?

Comment 3 Joe Morris 2001-03-03 14:08:45 UTC
Yes, I can indeed reproduce this with Wolverine. I tried setting KDE as my 
default desktop during the setup, and when I rebooted the screen blanked and 
the system froze while loading KDM. GDM works perfectly.

Comment 4 Bernhard Rosenkraenzer 2001-03-06 13:28:40 UTC
This could be a duplicate of bug #29627... Which graphics card are you using?


Comment 5 Joe Morris 2001-03-06 13:33:51 UTC
I'm not exactly sure, but I know it uses an S3 Savage4 chipset. I would like to add that the XFree86 4.0.2 Savage drivers don't work well. Could you make using XF86 4.0.2 an option during the install? 3.3.6 had better support.

Comment 6 Bernhard Rosenkraenzer 2001-03-06 13:38:22 UTC
Assigning to XFree86. Please try the current XFree86 packages from rawhide and 
let us know if this problem persists.



Comment 7 Mike A. Harris 2001-03-13 05:50:01 UTC
Please try XFree86-4.0.2-11.4.0 and Mesa-3.4-11 from:
ftp://people.redhat.com/mharris as well as Xconfigurator from Rawhide

Does this fix the problem for you?

Comment 8 Mike A. Harris 2001-03-13 05:53:28 UTC
Also, using XFree86 3 or 4 _is_ an option.  To use one or the other use:
Xconfigurator --preferxf3
or
Xconfigurator --preferxf4





Note You need to log in before you can comment on or make changes to this bug.