Bug 29160 - Package does not automatically restart crond after upgrade
Package does not automatically restart crond after upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 20:18 EST by Don Jordan
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-21 03:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Jordan 2001-02-23 20:18:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; ZDNetSL)


The vixie-cron-3.0.1-61.i386.rpm released last week as an upgrade to the 
RH package does not automatically restart the cron daemon after upgrading.

Reproducible: Always
Steps to Reproduce:
1.Install package
2.
3.
Comment 1 Henri Schlereth 2001-02-23 23:00:00 EST
I can verify this I put this upgrade on 3 RH70 boxes and the results were the same as the original reporter. one machine was
reboot for other reasons so it started up crond just fine. But the other two I had to issue a restart. I suspect some post install
glitch.
Comment 2 Need Real Name 2001-02-26 11:33:51 EST
This nailed me, too.  RH 7.0 system, and I foolishly went several days without 
realizing that crond was dead.  This has had some ramifications now, which are 
mostly my fault since I *definitely* should have detected that crond was dead.  
Nevertheless, please fix the RPM!  Thanks.
Comment 3 Bill Nottingham 2001-02-26 13:32:48 EST
It stopped it but didn't start it?  That's odd.

I've just tried on two machines here; I can't duplicate this behavior.
Each time the cron daemon does get restarted.
Comment 4 Need Real Name 2001-02-26 13:37:59 EST
Tough call to make on the erratic behavior, but my crond process died like a 
foot fungus in a pool of Tenactin.
Comment 5 Bill Nottingham 2001-02-26 15:25:33 EST
I've tried on various machines to verify this and I can't.

What do the log messags from cron look like around the time the
package is upgraded?
Comment 6 Need Real Name 2001-02-26 16:14:02 EST
No messages, really.  Just "Feb 20  10:49:25  mysys crond: crond shutdown 
succeeded."  Now, this is immediately preceeded by the message for me su-ing to 
root to run "rpm -Fvh vixie-cron..."  That's it.  I have some software 
(Mailman, which I noticed that Bugzilla is run with) that runs a script from 
cron every minute.  The entries cease at 10:49 and never start again until 
today when I figured out what was up and restarted crond.
Comment 7 Bill Nottingham 2001-02-26 16:16:07 EST
What does 'rpm -V vixie-cron' say?
Comment 8 Don Jordan 2001-02-26 16:23:13 EST
The following are from logcheck:

Feb 22 10:01:05 system1 sudo:...COMMAND=/bin/rpm -Fvh vixie-cron-3.0.1-
61.i386.rpm *** Upgrade initiated
Feb 22 10:01:07 system1 crond: crond shutdown succeeded ***Begin upgrade
Feb 22 12:21:12 system1 crond: crond shutdown failed *** Restarting crond, 
notice stop failed, it was not running
Feb 22 12:21:13 system1 crond: crond startup succeeded *** Restarting crond

These entries are from the cron log just before the upgrade and when I manually 
restarted crond:

Feb 22 10:01:01 system1 CROND[32720]: (root) CMD (run-parts /etc/cron.hourly)
Feb 22 12:21:12 system1 crond[762]: (CRON) STARTUP (fork ok)
Comment 9 Need Real Name 2001-02-26 16:26:04 EST
Well, "rpm -V vixie-cron" produces no output...literally.
Comment 10 Bill Nottingham 2001-02-26 16:27:16 EST
OK, it appears in both cases that it's shutting crond down but not
starting it. This is really odd.

What version of initscripts do you have installed?
Comment 11 Need Real Name 2001-02-26 16:30:06 EST
I've got initscripts-5.49-1 (5.49).
Comment 12 Don Jordan 2001-02-26 17:49:27 EST
Same info as dan@tri-8.com. initscripts-5.49-1 and no info from -V vixie-cron
Comment 13 Don Jordan 2001-02-26 17:56:39 EST
Same as previous poster.
initscripts-5.49-1 and no output from "rpm -V vixie-cron".
Comment 14 Need Real Name 2001-02-27 12:14:40 EST
I've got another big problem, which I probably will need to submit a new bug 
for.  With all this talk about crond, check this out: now that I've got this 
new vixie-cron-3.0.1-61, my crons are all running incorrectly.  I'm getting 
*duplicate* runnings, but not every time.  For instance, one cron entry runs 
at "0 23 * * *", which is 11:00 each night.  Well, according to my cron logs, 
the command was issued at 10:59:59 and then *AGAIN* at 11:00:00 (one second 
later).  This was a backup software command, so the backup got all messed up 
because two instances were fired up at almost the same time.  I looked in the 
cron logs, and my "minutely" mailman cron is doing the same thing: it runs at 
xx:xx:59 and then at xx:xx+1:00 (one second later), but not every time.  Some 
times it just runs at xx:xx:00.  I'm about 4 minutes away from getting the old 
version of vixie-cron off of the CD and putting it back.  Can anyone tell me 
what's up!?
Comment 15 Don Jordan 2001-02-27 12:27:28 EST
In response to crontab errant behavior, I have experienced none and logs are 
clean. And new jobs that I have submitted to crontab execute as excpected.
Comment 16 C. Ray Ng 2001-05-21 11:57:16 EDT
After upgrading vixie-cron-3.0.1-61, all /var/log/cron.* are empty. It looks
like some
of the messages were sent to /var/log/messages.
Comment 17 Jens Petersen 2003-02-19 08:26:03 EST
Are you still seeing this with recent RHL releases?
Comment 18 Need Real Name 2003-02-19 10:49:46 EST
Well, I don't think so.  Can't even remember if I've specifically upgraded cron
separately on newer releases (I do apply all of the released errata).  Afraid I
can't help much on that one.
Comment 19 Jens Petersen 2003-02-21 03:02:34 EST
I can't reproduce this with current rawhide at least.
I suspect that it is probably ok in recent releases too.
Please re-open if there is still a problem.

Note You need to log in before you can comment on or make changes to this bug.