Bug 291931 - ImageMagick depends on windows fonts
ImageMagick depends on windows fonts
Status: CLOSED DUPLICATE of bug 193474
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
http://rubyforge.org/tracker/index.ph...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 03:46 EDT by Conrad Meyer
Modified: 2008-10-13 03:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 02:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Meyer 2007-09-15 03:46:19 EDT
Description of problem:
Fedora's ImageMagick is configured with --with-windows-font-dir. Fedora 
doesn't ship windows fonts (as far as I know) and when you enable this option 
in configure, programs/libraries that use ImageMagick (RMagick for example) 
may assume that if ImageMagick was configured --with-windows-font-dir, that 
they can directly reference windows font files. (RMagick goes for verdana and 
arial font files (/usr/share/fonts/default/TrueType/verdana.ttf, etc.)

Version-Release number of selected component (if applicable):
Latest (ImageMagick-6.3.2.9-3.fc7).

How reproducible:
Always (unless windows fonts are installed).
  
Actual results:
Library (RMagick) using ImageMagick fails to load the windows fonts 
that --with-windows-font-dir implies.

Expected results:
Libraries are not mislead, and Fedora excludes the --with-windows-font-dir 
option as we do not ship windows fonts.
Comment 2 Hans de Goede 2008-04-26 02:23:28 EDT
Quick intro: I'm now a comaintainer of ImageMagick, and thus going through all
the open bugs.

This bug is a duplicate of bug 193474, marking as such.

Note this bug is fixed since atleast F-8.


*** This bug has been marked as a duplicate of 193474 ***
Comment 3 Chris Langlands 2008-10-12 21:55:25 EDT
This bug remains in RHEL5 as up Update 2
Comment 4 Hans de Goede 2008-10-13 03:00:17 EDT
(In reply to comment #3)
> This bug remains in RHEL5 as up Update 2

Dear sir,

This bug was filed against Fedora, and as such this issue is fixed in Fedora. If you want to see this fixed in RHEL, you need to open an issue with RHEL support for this.

Note You need to log in before you can comment on or make changes to this bug.