Bug 292021 - Foomatic selects wrong PPD for Brother HL2040
Summary: Foomatic selects wrong PPD for Brother HL2040
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-15 12:20 UTC by Peter H. Jones
Modified: 2008-09-04 14:53 UTC (History)
0 users

Fixed In Version: 3.0.2-65.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 14:53:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter H. Jones 2007-09-15 12:20:15 UTC
Description of problem:
Wrong PPD selected by default, had to manually select

Version-Release number of selected component (if applicable):
foomatic-3.0.2-50.fc8
gutenprint-foomatic-5.0.1-4.fc8

How reproducible:
Try to add USB-connected Brother HL2040

Steps to Reproduce:
1. Sysem-Administration/Printing
2. Enter root password
3. Select New Printer, and follow the dialogs, accepting
HL-2060 Postscript PPD (recommended)
  
Actual results:
Selected driver printed 2 empty pages on a 1-page document

Expected results:
Printing the document normally

Additional info:
Works if I manually select Brother HL-2060 Foomatic/hpijs
instead of the "recommended" one.

Marked as Platform all, but only tested on i686.

Comment 1 Tim Waugh 2007-09-21 14:35:57 UTC
This should be fixed in foomatic-3.0.2-51.fc8 -- hl1250 driver is recommended
for that model now.

Comment 2 Peter H. Jones 2007-09-22 23:19:15 UTC
I deleted my printer and tried re-adding.

The printer installar now suggests: 
URI usb://Brother/HL-2040%20series and
Brother HL-2060 Foomatic/Postscript 

When I try to print a single sheet as a test page, a blank sheet feeds through,
and the printer tries to feed more pages.

If I manually set the PPD to Brother HL-2060 Foomatic/hl1250, the test page
prints. Also, the word '(recommended)' appears in the basic settings.

So installation still isn't just clicking OK as yet.


Comment 3 Tim Waugh 2007-09-24 12:56:52 UTC
Please connect the printer and attach the output of this command:

  /usr/sbin/lpinfo -l -v

Thanks.

Comment 4 Peter H. Jones 2007-09-24 13:58:41 UTC
The relevant portion of the output is:
Device: uri =
hal:///org/freedesktop/Hal/devices/usb_device_4f9_28_C5J556102_if0_printer_noserial
        class = direct
        info = Brother HL-2040 series
        make-and-model = Brother HL-2040 series
        device-id = MFG:Brother;MDL:HL-2040 series;CLS:PRINTER;
Device: uri = usb://Brother/HL-2040%20series
        class = direct
        info = Brother HL-2040 series USB #1
        make-and-model = Brother HL-2040 series
        device-id = MFG:Brother;CMD:PJL,HBP;MDL:HL-2040 series;CLS:PRINTER;


Comment 5 Tim Waugh 2007-09-25 12:25:11 UTC
I see what the problem is now: the part of system-config-printer that chooses
preferred drivers was not able to see which driver foomatic recommends.  I've
fixed it now in:

system-config-printer-0.7.74.2-3.fc8
cups-1.3.2-3.fc8

(both packages are required for the fix to work)

Comment 6 Peter H. Jones 2007-10-12 23:00:56 UTC
The hl1250 driver doesn't seem to work with my printer. When I use this driver,
Ixget 2 similar columns with repeating text. If I manually select  Postscript,
the 8.next one down, I get several blank pages. hpijs makes the printer work OK.


Comment 7 Tim Waugh 2008-01-10 17:39:22 UTC
HPIJS (an HP printer driver) works for a Brother printer?  Are you sure?

How do you have this printer configured now?

Comment 8 Peter H. Jones 2008-01-12 05:31:36 UTC
I have
system-config-printer-libs-0.7.74.4-3.fc8
cups-1.3.4-4.fc8
installed.

I have two instances installed. One is
Brother HL-2060 Foomatic/hl1250 (recommended) ; test page prints OK.
The other is Brother HL-2060 Foomatic/hpijs ; again the test page prints OK.

Both pages say Postscript Level 3, Version 3010 (861), Product GPL: Ghostscript
Serial #:42 .


Comment 9 Tim Waugh 2008-01-15 12:32:07 UTC
I've asked about this upstream.

Comment 10 Tim Waugh 2008-06-02 11:10:38 UTC
Remaining issues are:

1. recommended driver should be hpijs not hl1250
2. IEEE 1284 ID should be recorded in foomatic

Comment 11 Peter H. Jones 2008-07-18 14:41:22 UTC
I now have
foomatic-3.0.2-59.fc9.i386
gutenprint-5.0.2-2.fc9.i386
cups-libs-1.3.7-8.fc9.i386
system-config-printer-libs-0.7.82.5-1.fc9.i386

/usr/sbin/lpinfo -l -v gives:
...
Device: uri =
hal:///org/freedesktop/Hal/devices/usb_device_4f9_28_C5J556102_if0_printer_noserial
        class = direct
        info = Brother HL-2040 series
        make-and-model = Brother HL-2040 series
        device-id = MFG:Brother;MDL:HL-2040 series;CLS:PRINTER;
Device: uri = usb://Brother/HL-2040%20series
        class = direct
        info = Brother HL-2040 series USB #1
        make-and-model = Brother HL-2040 series
        device-id = MFG:Brother;CMD:PJL,HBP;MDL:HL-2040 series;CLS:PRINTER;
...

Tried adding the printer. I was offered and took:
Device URI: usb://Brother/HL-2040%20series (no 2060 is offered)
Brother HL-2060 Foomatic/hl1250 (recommended)

Printing test page with default options works. Printing with 1200x600 dpi simply
feeds paper without printing. 600x600 dpi works, giving a finer texture to the
printout, as expected.


Comment 12 Tim Waugh 2008-09-02 16:31:41 UTC
(In reply to comment #10)
> 2. IEEE 1284 ID should be recorded in foomatic

Fixed upstream.  Just the recommended driver to fix now.

Comment 13 Tim Waugh 2008-09-03 09:08:19 UTC
Reported upstream:
  http://bugs.linux-foundation.org/show_bug.cgi?id=166


Note You need to log in before you can comment on or make changes to this bug.