Bug 29205 - Disk druid (both text and GUI) has error when creating partitions.
Disk druid (both text and GUI) has error when creating partitions.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 14:08 EST by Sheffer Clark
Modified: 2007-03-26 23:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 11:22:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sheffer Clark 2001-02-24 14:08:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Disk druid gives error "/... Couldn't fit boot partition.

System has a 45GB WD drive, 440BX motherboard, Celeron 400MHz processor.  
Linux shares disk with Windows 2000 and I use Windows' boot manager or 
floppy disk to launch Linux.

This only occurs with Fisher, I had no problem with RedHat 7.0 or other 
distributions.  I had to use RedHat 7.0 (or PartitionMagic) to create my 
Linux partitions and then install 'Fisher.'  If I have don't create the 
partitions first or delete them with Disk Druid when installing 'Fisher', 
I can not add them back again.  The install proceeded well after that but 
had another problem when kdm launched (See bug report against kdm.).

I also noted that when 'Fisher' installed it took a lot longer than RedHat 
7.0 to run ananconda (1 - 2 minutes longer). It spent a lot of time 
accessing the hard disk and CDROM (access lights flashed back and forth).  
If not for the disk lights I would have though it had died. This also 
happened at another point in the installation before ananconda.

Reproducible: Always
Steps to Reproduce:
1. Started installation of 'fisher' from CDROM
2. Tried to use Disk Druid to configure 45GB hard disk
3.
Comment 1 Michael Fulbright 2001-02-25 11:20:41 EST
Please give the original partition state of your system and the partition state
when you are trying to add the '/' partition.

Most likely you are trying to add '/' and there is only space about the 1024
cylinder limit, so the allocation fails (since we can only be sure that BIOS
will boot from below the 1024 cylinder limit).
Comment 2 Glen Foster 2001-02-26 18:57:28 EST
We (Red Hat) should really try to resolve this before next release.
Comment 3 Sheffer Clark 2001-03-05 11:22:29 EST
I am installing the boot partition about the 1024 cylinder limit.  I tried 
the "Wolverine" beta version and it also returned an error, but gave a clearer 
message, saying the boot sector was greater than the 1024 limit.  However, 
RedHat 7.0 allowed me to create a boot partition above this limit.  I did have 
to change the lilo.conf file to use 'LBA32'  to get lilo to work.  'Wolverine' 
gave a warning message after the disk druid saying that the BIOS appeared to 
support LBA. Shouldn't disk druid give a warning but still allow you to create 
the partition?
Comment 4 Michael Fulbright 2001-03-05 15:15:29 EST
Because of the problems we've seen with different BIOSs returned erroneous
information about whether or not they support LBA32, we opted to not let disk
druid create partitions which extend above the 1024 cylinder limit
automatically. If you make a partition with the fdisk program, then assign it to
'/' (or '/boot') in the disk druid screen, it will let you use it.

Be sure you make a boot floppy no matter what you do, in case something goes
wrong with your motherboard/LILO interaction.

Note You need to log in before you can comment on or make changes to this bug.