Bug 292161 - Stalled Samba transfers on RealTek RTL8111/8168B gigabit NIC
Stalled Samba transfers on RealTek RTL8111/8168B gigabit NIC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 14:54 EDT by Mikkel Lauritsen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.9-91.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 10:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikkel Lauritsen 2007-09-15 14:54:52 EDT
Running F7 on an Asus A2N-VM motherboard with a built-in RealTek RTL8111/8168B
gigabit NIC. 

When streaming files using Samba to a networked media player the transfer oftens
hangs. The client only reads data at a relatively low rate, and that might be
part of the reason why the bug is triggered. When transferring data to a laptop
computer I get 9.5 MB/s sustained on a 100 Mbit connection, so I don't think
there are any problems with the network hardware.

The problem occurs with the realtek 8169 driver in the 2.6.22.5-76.fc7 kernel,
samba 3.0.26a-0. Same kernel version but another NIC does not show the same
behavior.

To reproduce it I just need to start playing a song, causing the media player
to read a .FLAC file from the samba share. After a while the media player will
start dropping out and complaining that the transfer is stopped. netstat -t then
shows a large Send-Q for the samba connection.

So far only Samba is affected, and doing something else that exercises the
network interface (like running wireshark to dump the traffic) makes the problem
disappear.

Apparently the exact same problem is described in several other places:

http://bugzilla.kernel.org/show_bug.cgi?id=7555
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/114171
http://lists.samba.org/archive/samba/2007-January/128814.html
http://lists.samba.org/archive/samba/2006-April/119726.html
Comment 1 Mikkel Lauritsen 2007-09-17 15:45:10 EDT
Looking further at this, I haven't been able to reproduce the slowdowns with
other services than Samba.

Oh, and it's Asus M2A, not A2N. Not that it matters a lot :-)
Comment 3 Mikkel Lauritsen 2007-09-25 14:59:11 EDT
The link to a kernel bugzilla bug in the original bug here should probably be
replaced by

http://bugzilla.kernel.org/show_bug.cgi?id=7924

as this one is still open.
Comment 4 Mikkel Lauritsen 2007-09-27 14:52:40 EDT
Replacing the 2.6.22.x r8169.ko module with one built from the 2.6.23-rc8 source
makes the problem disappear, and so far I have experienced no bad side effects.
Comment 5 Chuck Ebbert 2007-09-27 15:23:32 EDT
2.6.22.9 kernel with the two patches is in koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=19726
Comment 6 Chuck Ebbert 2007-09-28 13:42:45 EDT
In 2.6.22.9-91, in updates-testing soon.
Comment 7 Mikkel Lauritsen 2007-09-30 14:20:48 EDT
I have just tested, and 2.6.22.9-91 fixes the problem - many thanks.

Note You need to log in before you can comment on or make changes to this bug.