Bug 292191 - oops on pccard
oops on pccard
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 16:52 EDT by g. artim
Modified: 2007-12-06 18:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 18:52:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description g. artim 2007-09-15 16:52:21 EDT
Description of problem: (system hangs, get this on console:)
Sep 15 10:25:20 localhost kernel: pccard: CardBus card inserted into slot 0
Sep 15 10:25:20 localhost kernel: PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
Sep 15 10:25:20 localhost kernel: ACPI: PCI Interrupt 0000:03:00.0[A] -> Link
[LNKF] -> GSI 9 (level, low) -> IRQ 9
Sep 15 10:25:20 localhost kernel: ath_pci 0000:03:00.0: AR5212 chip found: mac
7.7 phy 4.5
Sep 15 10:25:21 localhost kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000000
Sep 15 10:25:21 localhost kernel:  printing eip:
Sep 15 10:25:21 localhost kernel: e0c42882
Sep 15 10:25:21 localhost kernel: *pde = 0ede0067
Sep 15 10:25:21 localhost kernel: *pte = 00000000
Sep 15 10:25:21 localhost kernel: Oops: 0000 [#1]
Sep 15 10:25:21 localhost kernel: SMP
Sep 15 10:25:21 localhost kernel: Modules linked in: arc4 ecb blkcipher
rc80211_simple ath5k mac80211 cfg80211 autofs4 nf_conntrack_ipv4 xt_state
nf_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables rfcomm l2cap
bluetooth sunrpc loop dm_multipath video output sbs bay radeon drm ipv6
snd_intel8x0m snd_intel8x0 snd_ac97_codec ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq e100 firewire_ohci firewire_core snd_seq_device
sony_laptop crc_itu_t mii snd_pcm_oss battery ac snd_mixer_oss parport_pc
parport iTCO_wdt snd_pcm iTCO_vendor_support usb_storage button i2c_i801
snd_timer snd i2c_core rtc_cmos intel_rng soundcore snd_page_alloc sg sr_mod
cdrom joydev dm_snapshot dm_zero dm_mirror dm_mod ata_piix ata_generic libata
sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Sep 15 10:25:21 localhost kernel: CPU:    0
Sep 15 10:25:21 localhost kernel: EIP:    0060:[<e0c42882>]    Not tainted VLI
Sep 15 10:25:21 localhost kernel: EFLAGS: 00210246   (2.6.23-0.184.rc6.git4.fc8 #1)
Sep 15 10:25:21 localhost kernel: EIP is at ath5k_hw_reset+0x51d/0xf11 [ath5k]
Sep 15 10:25:21 localhost kernel: eax: 00000000   ebx: e0c48914   ecx: 00000000
  edx: 00000004
Sep 15 10:25:21 localhost kernel: esi: 00000000   edi: 00000000   ebp: ce90ae10
  esp: ce90adac
Sep 15 10:25:21 localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Sep 15 10:25:21 localhost kernel: Process ip (pid: 3081, ti=ce90a000
task=ce8b0000 task.ti=ce90a000)
Sep 15 10:25:21 localhost kernel: Stack: 00000000 ce90adf4 e0c3b4e0 cecf9228
dc665060 00000002 cecfb5e4 cecfb5dc
Sep 15 10:25:21 localhost kernel:        00000000 00000000 00000001 e0c2da6e
00000003 00000001 00000002 00000014
Sep 15 10:25:21 localhost kernel:        ce90adf4 00000000 00000000 00000000
cecf9040 cf3e8600 cf3e8000 cecf9040
Sep 15 10:25:21 localhost kernel: Call Trace:
Sep 15 10:25:21 localhost kernel:  [<c04063c7>] show_trace_log_lvl+0x1a/0x2f
Sep 15 10:25:21 localhost kernel:  [<c0406477>] show_stack_log_lvl+0x9b/0xa3
Sep 15 10:25:21 localhost kernel:  [<c0406637>] show_registers+0x1b8/0x289
Sep 15 10:25:21 localhost kernel:  [<c040681f>] die+0x117/0x24a
Sep 15 10:25:21 localhost kernel:  [<c0635d2c>] do_page_fault+0x51c/0x5ed
Sep 15 10:25:21 localhost kernel:  [<c0634452>] error_code+0x72/0x78
Sep 15 10:25:21 localhost kernel:  [<e0c3ba7b>] ath_init+0x74/0xfb [ath5k]
Sep 15 10:25:21 localhost kernel:  [<e0c3bb98>] ath_open+0xb/0xd [ath5k]
Sep 15 10:25:21 localhost kernel:  [<e0c1a70e>] ieee80211_open+0x259/0x320
[mac80211]
Sep 15 10:25:21 localhost kernel:  [<c05cf7d2>] dev_open+0x31/0x6c
Sep 15 10:25:21 localhost kernel:  [<c05cd929>] dev_change_flags+0xa3/0x156
Sep 15 10:25:21 localhost kernel:  [<c060e1c1>] devinet_ioctl+0x207/0x50e
Sep 15 10:25:21 localhost kernel:  [<c060e86f>] inet_ioctl+0x86/0xa4
Sep 15 10:25:21 localhost kernel:  [<c05c3b02>] sock_ioctl+0x1ac/0x1c9
Sep 15 10:25:21 localhost kernel:  [<c0493d26>] do_ioctl+0x22/0x68
Sep 15 10:25:21 localhost kernel:  [<c0493fb5>] vfs_ioctl+0x249/0x25c
Sep 15 10:25:21 localhost kernel:  [<c0494011>] sys_ioctl+0x49/0x64
Sep 15 10:25:21 localhost kernel:  [<c0405192>] syscall_call+0x7/0xb
Sep 15 10:25:21 localhost kernel:  =======================
Sep 15 10:25:21 localhost kernel: Code: 00 00 03 5a 08 89 fa c7 44 24 04 00 00
00 00 0f b6 46 1c 89 04 24 8b 45 ac e8 a3 b9 ff ff 89 da 0f b7 c0 e8 c0 13 8c df
ff 45 e8 <0f> b7 07 83 c6 14 39 45 e8 72 b0 8b 4d ac 83 79 48 01 76 51 66
Sep 15 10:25:21 localhost kernel: EIP: [<e0c42882>] ath5k_hw_reset+0x51d/0xf11
[ath5k] SS:ESP 0068:ce90adac
Sep 15 10:25:47 localhost kernel: pccard: card ejected from slot 0
Sep 15 10:26:12 localhost gdm-binary[2529]: WARNING: gdm_slave_xioerror_handler:
Fatal X error - Restarting :0
Sep 15 10:29:01 localhost rsyslogd: [origin software="rsyslogd"
swVersion="1.19.2" x-pid="2115"][x-configInfo udpReception="No" udpPort="514"
tcpReception="No" tcpPort="0"] restart



Version-Release number of selected component (if applicable):


How reproducible:

have netgetar wpn511 plugged in at boot or plug in after boot (same oops)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2007-12-06 18:52:55 EST
Driver no longer oopses but may not work; see bug 254192

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.