Bug 292311 - Thinkpad T61: when using internal speakers, only left speaker works
Thinkpad T61: when using internal speakers, only left speaker works
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 01:01 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 08:46:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-09-16 01:01:47 EDT
Description of problem:
On a Thinkpad T61, when using internal speakers only the left one produces any
sound (using gnome-volume-control, if the left speaker volume is set to zero, no
sound is produced). With headphones plugged into the audio output jack, sound
works normally

Version-Release number of selected component (if applicable):
alsa-lib-1.0.14-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Play a stereo audio file
  
Actual results:
With internal speakers, only left speaker outputs any sound

Expected results:
Both speakers should produce sound

Additional info:
Comment 1 Michel Alexandre Salim 2007-09-16 01:03:39 EDT
It appears that the problem disappears after toggling the speaker switch (in
gnome-volume-control) on and off. Will investigate if right speaker is always
disabled on startup
Comment 2 Martin Stransky 2007-09-19 08:46:11 EDT
Aha, okay. Anyway, that could be a kernel issue (the speakers should be enabled
by drivers by default) so please reopen this bug for kernel (or report it to
ALSA project - www.alsa-project.org).
Comment 3 Jan Hutař 2007-10-20 19:22:15 EDT
Both speakers works for me as expected on T61 using:

alsa-lib-1.0.15-0.4.rc3.fc8
kernel-2.6.23.1-23.fc8

Note You need to log in before you can comment on or make changes to this bug.