Bug 292431 - Yum fails while checking dependencies
Yum fails while checking dependencies
Status: CLOSED DUPLICATE of bug 291471
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 07:51 EDT by Need Real Name
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 16:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-09-16 07:51:04 EDT
Description of problem: Yum fails resolving the dependencies for some packets. 
I can install/upgrade the packets wmanually with rpm though. This seems not to 
be related to one special packet, I had this for other packets some days ago as 
well but installed them all successfully with rpm. Now it fails again with the 
next set of new packets.

Version-Release number of selected component (if applicable): See trace


How reproducible: start yum update

  
Actual results:

Yum Version: 3.2.4
COMMAND: yum -d 10 -v update
Installroot: /
Reading Local RPMDB
Setting up Package Sacks
Excluding Packages in global exclude list
Excluding kernel-devel - 2.6.21-1.3194.fc7.i586
Excluding kernel-xen-devel - 2.6.20-2925.9.fc7.i686
Excluding kernel-xen - 2.6.20-2925.9.fc7.i686
Excluding kernel-PAE-debug-devel - 2.6.22.5-76.fc7.i686
Excluding kernel-debug-devel - 2.6.22.5-76.fc7.i686
Excluding kernel-PAE - 2.6.21-1.3194.fc7.i686
Excluding kernel-PAE-debug - 2.6.21-1.3194.fc7.i686
Excluding kernel-PAE-debug - 2.6.22.5-76.fc7.i686
Excluding kernel - 2.6.21-1.3194.fc7.i686
Excluding kernel-PAE-debug-devel - 2.6.21-1.3194.fc7.i686
Excluding kernel-devel - 2.6.21-1.3194.fc7.i686
Excluding telnet-server - 1:0.17-38.fc7.i386
Excluding kernel-PAE-devel - 2.6.22.5-76.fc7.i686
Excluding kernel-xen - 2.6.20-2931.fc7.i686
Excluding kernel-headers - 2.6.21-1.3194.fc7.i386
Excluding kernel - 2.6.22.5-76.fc7.i686
Excluding kernel-PAE - 2.6.22.5-76.fc7.i686
Excluding kernel - 2.6.21-1.3194.fc7.i586
Excluding kernel-xen-2.6-doc - 2.6.20-2931.fc7.noarch
Excluding kernel-debug - 2.6.22.5-76.fc7.i686
Excluding kernel-devel - 2.6.22.5-76.fc7.i686
Excluding kernel-headers - 2.6.22.5-76.fc7.i386
Excluding kernel-debug-devel - 2.6.21-1.3194.fc7.i686
Excluding kernel-debug - 2.6.21-1.3194.fc7.i686
Excluding kernel-devel - 2.6.22.5-76.fc7.i586
Excluding kernel-doc - 2.6.21-1.3194.fc7.noarch
Excluding kernel-doc - 2.6.22.5-76.fc7.noarch
Excluding kernel-xen-devel - 2.6.20-2931.fc7.i686
Excluding kernel - 2.6.22.5-76.fc7.i586
Excluding kernel-xen-2.6-doc - 2.6.20-2925.9.fc7.noarch
Excluding kernel-PAE-devel - 2.6.21-1.3194.fc7.i686
Finished
Setting up Update Process
Building updates object
putting cyrus-sasl-lib in complex update
putting pm-utils in complex update
putting samba-common in complex update
putting mmv in simple update
putting cyrus-sasl in complex update
putting cyrus-sasl-devel in complex update
putting glibc in complex update
putting libdhcp4client in complex update
putting vixie-cron in complex update
putting pm-utils in complex update
putting pm-utils in complex update
putting usermode in complex update
putting samba in complex update
putting pm-utils in complex update
putting cyrus-sasl-md5 in complex update
putting openssl in complex update
processing cyrus-sasl-lib
processing pm-utils
processing samba-common
processing cyrus-sasl
processing cyrus-sasl-devel
processing glibc.i386
processing libdhcp4client
processing vixie-cron
processing pm-utils
processing pm-utils
processing usermode
processing samba
processing pm-utils
processing cyrus-sasl-md5
processing openssl
Resolving Dependencies
1189943175.98
--> Running transaction check
Checking deps for samba-common.i386 0-3.0.25c-0.fc7 - None
---> Package samba-common.i386 0:3.0.26a-0.fc7 set to be updated
Checking deps for samba-common.i386 0-3.0.26a-0.fc7 - u
Checking deps for vixie-cron.i386 4-4.1-83.fc7 - None
---> Package samba.i386 0:3.0.26a-0.fc7 set to be updated
Checking deps for samba.i386 0-3.0.26a-0.fc7 - u
looking for (u'samba-common', u'EQ', (u'0', u'3.0.26a', u'0.fc7')) as a 
requirement of samba.i386 0-3.0.26a-0.fc7 - u
Checking deps for libdhcp4client.i386 12-3.0.5-38.fc7 - None
Checking deps for samba.i386 0-3.0.25c-0.fc7 - None
---> Package libdhcp4client.i386 12:3.0.5-39.fc7 set to be updated
Checking deps for libdhcp4client.i386 12-3.0.5-39.fc7 - u
Checking deps for usermode.i386 0-1.92-0.fc7 - None
---> Package vixie-cron.i386 4:4.1-84.fc7 set to be updated
Checking deps for vixie-cron.i386 4-4.1-84.fc7 - u
---> Package usermode.i386 0:1.93-1.fc7 set to be updated
Checking deps for usermode.i386 0-1.93-1.fc7 - u
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 565, in 
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 718, in 
resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 889, in 
_checkFileRequires
    dep = self.rpmdb.getProvides(name, flag, evr)
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 393, in 
getProvides
    morepkgs = self.searchFiles(name)
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 111, in 
searchFiles
    if not result.has_key(pkg.pkgid):
TypeError: list objects are unhashable
Comment 1 Seth Vidal 2007-09-17 16:24:11 EDT

*** This bug has been marked as a duplicate of 291471 ***

Note You need to log in before you can comment on or make changes to this bug.