This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 292441 - Cannot set home page to the above URL
Cannot set home page to the above URL
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
http://start.fedoraproject.org/
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 10:23 EDT by Michel Alexandre Salim
Modified: 2007-12-20 11:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-09-16 10:23:21 EDT
Description of problem:
The first time Firefox started, its home page is set to
http://start.fedoraproject.org/ -- this setting is not persisted, however (the
second time Firefox is run, I get a blank page). An attempt to set the homepage
URL back to this would cause the URL to be immediately erased, even before the
Preferences window is closed. If any other URL is used (including the same URL
without the trailing dash) the input is accepted as normal.

Version-Release number of selected component (if applicable):
firefox-2.0.0.6-8.fc8

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox
2. Edit->Preferences
3. Set home page to http://start.fedoraproject.org/
4. Navigate to the above URL
5. Edit->Preferences
6. Set home page to current URL
  
Actual results:
Both (3) and (6) results in the URL being immediately erased (the text input
remains empty)

Expected results:
The URL is entered properly

Additional info:
Comment 1 Michel Alexandre Salim 2007-11-15 18:13:54 EST
Looks like Firefox does not allow the same value to be used in
browser.startup.homepage and startup.homepage_override_url 
Comment 2 Matěj Cepl 2007-12-20 11:47:04 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.