Bug 292531 - Cannot allocate memory
Cannot allocate memory
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 13:35 EDT by Jakub 'Livio' Rusinek
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 16:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2007-09-16 13:35:48 EDT
Description of problem:
Everytime I'm installing or updating something, yum is doing what it has to do,
but with error.

error: Couldn't fork %post/%preun: Cannot allocate memory

Version-Release number of selected component (if applicable):
3.2.5-1

How reproducible:
Everytime

Steps to Reproduce:
1. Run yum
2. Wait
  
Actual results:
It doesn't exit with error, but doesn't install/update some packages (error with
%pre).

Expected results:
Everything working.

Additional info:

Kernel info:

[livio@castello ~]$ rpm -q kernel
kernel-2.6.22.4-65.fc7
kernel-2.6.22.5-76.fc7
[livio@castello ~]$ 

I think yum messed me in system (Fedora installed from runlevel 3 from LiveCD,
because of 128MB RAM).
Comment 1 Jakub 'Livio' Rusinek 2007-09-16 13:37:36 EDT
RPM is working alright - it's installing, updating without errors.
Comment 2 Seth Vidal 2007-09-17 16:34:19 EDT
I'm not sure how much we'll be able to support on 128M of ram. It just doesn't
work out for what we're doing.

Note You need to log in before you can comment on or make changes to this bug.