Bug 292641 - SELinux prevents loading nppdf.so plugin
SELinux prevents loading nppdf.so plugin
Status: CLOSED DUPLICATE of bug 250249
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-16 18:21 EDT by Burnie West
Modified: 2008-01-04 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-04 17:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Burnie West 2007-09-16 18:21:13 EDT
Description of problem:
SELinux is preventing /usr/lib/firefox- from loading
/usr/lib/firefox- which requires text relocation.

Noted that previous related bugs refer to FC5 and Adobe Reader 7.

Version-Release number of selected component (if applicable):
Firefox-; Adobe Reader 8.1.1 installed using AdobeReader_enu-8.1.1-1.i486.rpm

How reproducible:
Not sure. Appears to happen mainly on bootup when firefox is restoring a
previous session. SETroubleshooter reported 61 instances in two lines with the
same timestamp.

Steps to Reproduce:
1. Shut down and restart F7 Linux with open firefox windows.
2. Launch firefox estore interrupted session.
3. Restore interrupted session.
Actual results:
SETroubleshooter logs multiple load denials.

Expected results:
NO SELinux flags.

Additional info:
Comment 1 Zoltan Hoppar 2007-11-14 23:55:55 EST
Same happens with all mozilla capable browsers, like epiphany too, but with
always nppdf.so plugin.
Comment 2 Martin Stransky 2008-01-04 17:00:01 EST

*** This bug has been marked as a duplicate of 250249 ***

Note You need to log in before you can comment on or make changes to this bug.