Bug 29266 - Kernel hangs when creative labs CD is on IDE0 or IDE1
Kernel hangs when creative labs CD is on IDE0 or IDE1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 16:15 EST by Paul Watkins
Modified: 2008-08-01 12:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Watkins 2001-02-24 16:15:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


Under both Fisher and Wolverine the installer crashes (hangs) after loading
the aic7xxx module. This is true under graphics, text and expert mode.

Reproducible: Always
Steps to Reproduce:
1.Reboot with cd-rom
2.attempt various modes: expert, graphics, text, no frame buffer
3.loads aic7xxx modules and infinitely hangs
	

Actual Results:  Hangs systems must do cold restart to reboot computer

Expected Results:  Should have gone on to next installation step --
probably anaconda
Comment 1 Glen Foster 2001-02-26 18:56:56 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Michael Fulbright 2001-02-26 21:28:55 EST
QA has looked into this problem and is not seeing this with their hardware.

Which exact Adaptec controller are you using?

Comment 3 Paul Watkins 2001-02-27 04:14:32 EST
Adaptec model 2906  (connected to scanner) -- works fine with RH7, 2.2.17-14 

Other Info: 
IDE controller for hard drive, CD-RW, CD-ROM
Comment 4 Michael Fulbright 2001-02-27 18:29:04 EST
Do we have a 2906 in house?
Comment 5 Paul Watkins 2001-03-01 17:42:06 EST
Under RH 7, 2.2.17-14 , the installer loads the AHC 7850 module for the Adaptec
2906 SCSI -- works fine.

In further testing, removed 2906 card from machine, tried to install wolverine
-- machine hangs after initial screen for installation choices.   The 2906
configuration was not removed from system for this test.

Perhaps Anaconda is the culprit but can't be sure.

Machine is configured as follows:

Pentium II 400 Mghz Asus P2B 440Bx AGPset Motherboard
IDE controller: hard drive, cd-rom, cd-rw
US Robotics 3CP5610A Modem (Performance Pro)
Linksys EhterPCI ethernet card 
D-Link DFE-530TX ethernet card
196 Meg Ram
Adaptec 2906 SCSI Card - external connection to scanner
Iomega ditto - tape drive
Matrix Millenium Graphics Card - 8 meg.
Comment 6 Michael K. Johnson 2001-03-07 17:17:06 EST
QA tried to reproduce this with a 2904 (closest thing we have in house
to a 2906) with no luck.

Now that you say that it hangs even with the 2906 removed, it is
probably being caused by something else.  I assume that the installer
did not try to load the aic7xxx module with the 2906 card removed
from the machine, right?

If I'm right, what is the last thing that happens now?
Comment 7 Paul Watkins 2001-03-07 17:48:44 EST
With the 2906 card removed, the installer just hangs --- no messages of any
kind.  To recap, upon boot the menu of install choices comes up.  I can select,
graphics, text, expert and so on.  With any choice selcted I'm transferred to a
blue screen and the system immediately hangs. I can only restart by hitting the
restart button on the computer.

I know it is not a kernel or module problem because since initiating the bug
report, I have compiled kernel 2.4.2 and installed it and everything works fine
including the 2906 card.
Comment 8 Paul Watkins 2001-03-09 04:48:05 EST
I've isolated the source of the problem.

As mentioned above: I have a cd-rom and a cd-rw drive both connected to the 
IDE controller. The cd-rw drive (Ricoh 7083A) is the master on the ide1 and 
the cd-rom is the slave on ide0.

RH7.0, kernel 2.2.17-14 setup the cd-rw drive as the "boot" cd-drive. I've 
been installing by booting the cd-rw drive.  This works for RH7.0 install but 
not Wolverine.

I disconnected the cable from the CD-RW drive and restarted the computer. Then 
I tried to install Wolverine from the CD-Rom drive.  It worked!

Then after the install of Wolverine, I reconnected the CD-RW drive and it now 
functions properly. 

So here are my conclusions:

1. After the initial phase of the install from the cd-rw drive (after the scsi 
driver loads -- Aic7xxx) the install program cannot find the cd-rw drive ...

or 

2. There is some conflict between the two cd drives during install but this 
doesn't make sense since the install starts fine from the cd-rw drive but 
hangs as described in the earlier discussion of this bug.

3. The problem definately resides in the install program and is definately 
related to the 2 drive issue.
Comment 9 John Messina 2001-03-13 13:45:18 EST
I have the same issue.  The installation hangs after attempting to load the 
aic7xxx module.  I've tried the graphics, text, low-res, noframe modes.  This 
occurred on both fisher and wolverine.

Machine is configured as follows:

Pentium 133 Mghz Iwill P55VT Motherboard
AHA-2940U SCSI controller (on motherboard): hard drive, cd-rom
3Com 3C590 ethernet card 
Zoom ISA Fax/Modem
32 Meg Ram
Matrix Millenium Graphics Card - 4 meg.
Comment 10 Doug Ledford 2001-03-14 23:58:29 EST
John, your problem is decidedly different from that of the original poster. 
Please open a different bug for your problem (the original poster's problem in
this case is a conflict between which IDE cdrom the installer sees as the boot
cdrom vs. what the BIOS sees as the boot cdrom, and since you don't have any IDE
cdroms, it can't be the same bug).  Also, please include a listing of what
kernel messages, if any, are displayed on VT3 or VT4 (I can't remember which one
is the kernel messages screen) when booting up your system and it hanging on the
aic7xxx driver.

As to the original poster's problem.  I agree, it's definately an installer
problem, most likely as I mentioned it is the installer and the BIOS disagreeing
about the boot CD-ROM or something like that.  The install team will have to
help you through that, I'm not much use here ;-)  Pong, back to you Dr. Mike.
Comment 11 Michael Fulbright 2001-03-20 14:17:28 EST
If you boot from the cd-rw, what does /proc/scsi/scsi say? This is how the
installer finds the drive.
Comment 12 Paul Watkins 2001-03-20 20:42:09 EST
Contents of /proc/scsi/scsi

Attached devices:
Host: scsi0 Channel: 00 Id: 06 Lun: 00
     Vendor: HP        Model: C1750A  Rev:  3125
     Type:   Processor                ANSI SCSI revision: 01
Host: RICOH  Model: CD-R/RW  MP7083A   Rev: 1.10
     Type: CD-ROM                      ANSI SCSI revision: 02

Also: /proc/scsi directory contains
aic7xxx      ide-scsi  scsi

the aic7xxx directory contains a value of 0 and the ide-scsi directory 
contains a value of 1


Comment 13 Michael Fulbright 2001-04-02 11:25:44 EDT
A new behavior this release is we detected IDE CD-R/W drives and add the
ide-scsi module (required to burn CDs).  I wonder if this is masking the Adaptec
controller?


I find it odd the /proc/scsi/scsi output has 'ide-scsi' in it.

I don't think we load the ide-scsi module during an install however.

Any ideas Matt or Erik?
Comment 14 Matt Wilson 2001-04-02 11:32:01 EDT
we don't load ide-scsi in the installer.
Comment 15 Paul Watkins 2001-04-02 20:55:29 EDT
The ide-scsi is activated because of this statement in lilo.conf:
append=''hdc=ide-scsi" which is necessary to have the generic scsi support find
the ide-cd R/W device which is on the ide interface rather than on a "pure" scsi
interface.
Comment 16 Matt Wilson 2001-04-02 21:15:06 EDT
this is surely a kernel bug and not an anaconda bug.
Comment 17 Doug Ledford 2001-04-03 04:31:14 EDT
In order to try and isolate where the problem is, try booting the machine with
the boot disk and use this boot command:

linux text noprobe

and see if the machine still locks up with both CD drives installed (the aic7xxx
card is optional, it isn't the problem anyway).
Comment 18 Paul Watkins 2001-04-03 04:58:06 EDT
booting from the wolverine CD and entering
linux text noprobe has the same result as other methods -- hangs the machine
Comment 19 Doug Ledford 2001-04-03 05:04:48 EDT
At the time that you get the blue screen and the hang, does simple things like
the CapsLock key still work (aka, does hitting it repeatedly cause the LED on
the keyboard to go on and off)?
Comment 20 Paul Watkins 2001-04-03 05:17:36 EDT
Everything goes dead -- no caps lock, scroll lock, num lock off and on action.
There is no response from those keys with repetitive off/on actions.
Comment 21 Doug Ledford 2001-04-03 05:24:58 EDT
OK, that means the problem is actually related to the IDE drivers in the kernel
and it is resulting in hard lockups of the machine while probing the IDE bus. 
There is a chance that a well crafted IDE command line might help, but since I
don't know how to build it that won't help.  Try the latest boot image from the
latest tree and see if kernels after .40 do any better (I'm not holding my
breath though).
Comment 22 Paul Watkins 2001-04-03 05:59:32 EDT
I assume you mean trying a boot image which is burned on the cd to attempt to
see if later kernel's boot images will work during install.

Boot images on the hard drive have no problem.
Comment 23 Doug Ledford 2001-04-03 06:07:54 EDT
No, I just mean boot with the latest boot disk (whether via a CD boot or a
floppy boot doesn't matter to me) in order to see if the latest boot kernel
still hangs the system when it finds both CD drives.  If it was locking up using
the net-boot image before, then use it again but from the later tree so it has
the later kernel is what I'm talking about.
Comment 24 baulv 2001-04-13 13:13:11 EDT
I have posted some of this info on the Wolverine list, but here's a recap:


A  CREATIVECD 3630E drive was my  boot-CD, when the RedHat 
Wolverine installer (expert mode) came to a blue screen "Do you have a 
driver CD  > No " it would no longer read the CD. The installation could 
ONLY be continued after the install CD was moved to the IDE 
CD-RW-DVD. (Ricoh MP9120A) 
After the insatll was completed the Creative Labs 3630 CD-ROM can be 
mounted BUT a warning window pops up saying "/mnt/cdrom does not 
exist". 
Before the ~ 270 meg "up2date" I got other error messages. On one 
lonely occasion the thing would work and was mounted as /dev/hdd not 
/dev/cdrom. On the RH 7.0 the CreativeLabs 3630 worked really dandy. I've 
tried different fstab configs, disabling DMA in BIOS, moving to another 
IDE channel on the MoBo, no GO.  The MoBo is an Abit BH6 with a QN 
BIOS rev. 

During bootup I got a Dmesg  :

"Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with 
idebus=xx"

 Is this assumption wrong if my IDE bus is run at  41.33 Mhz ? ? 
Or does the 
 " ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA " 
  override the  PIO-timing? (incidentally, my BIOS setting is NOT DMA but 
 PIO4 for IDE 1).  
Are we looking at a timing issue ? 
From console I get a "bash: cd: /mnt/cdrom: Input/output error " when 
trying  to mount it.
Originally the CreativeLabs 3630 was Slave on IDE 0, I tied to move it to 
Slave on IDE 1 with equal results. 

Then I got the idea to move the CreativeLabs 3630 to the IDE 3on my 
Promise Ultra66  as Master.  (the IDE 2 holds two Windoze HD's, 
non-powered during Linux use)

Lo and fikkin behold,  it worked, I can now mount the CreativeLabs 3630 ! !

This is from my last /var/log/dmesg

<snip>
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:pio
PDC20262: IDE controller on PCI bus 00 dev 68
PCI: Found IRQ 12 for device 00:0d.0
PDC20262: chipset revision 1
PDC20262: not 100% native mode: will probe irqs later
PDC20262: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI 
Mode.
    ide2: BM-DMA at 0xec00-0xec07, BIOS settings: hde:DMA, hdf:DMA
    ide3: BM-DMA at 0xec08-0xec0f, BIOS settings: hdg:pio, hdh:pio
hda: WDC AC35100L, ATA DISK drive
hdc: RICOH DVD/CDRW MP9120, ATAPI CD/DVD-ROM drive
hdg: CREATIVECD3630E, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide3 at 0xe400-0xe407,0xe802 on irq 12
hda: 10085040 sectors (5164 MB) w/256KiB Cache, CHS=627/255/63, 
UDMA(33)
<snip>

So far I've tested two different IDE channels off the same onboard 
controller, at the same position, and a different IDE controller in a 
different position. To rule out conflicts with the RedHat driver and the 
onboard IDE controller I will next try torun the 3630E as Master on IDE 0 
and IDE 1.

BRB



Comment 25 baulv 2001-04-13 13:35:41 EDT
....OK 

I moved the CreativeLabs 3630E to IDE 1 as single Master.
(where it assumed the " append="hdc=ide-scsi " identity.

No mounting.  I get a box saying:
"could not mount device. ..../dev/cdrom1: input ouput error.
mount: I could not determine the filesystem type, and none was 
specified"

...which is not true because it mounts fine with the Ricoh. This is the line 
from "fstab"

/dev/cdrom1       /mnt/cdrom1      auto    noauto,owner,kudzu,ro 0 0

It looks more like a conflict between the Intel PIIX4  IDE controller and 
the code in the Wolverine.

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with 
idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1




Comment 26 Mark Goodwin 2001-04-17 00:08:29 EDT
Installing seawolf on an SGI-1200 with adaptech-7896 controller: installer hangs
displaying "Loading aic7xxx" message. ALT-F3 shell is alive and /proc/modules
shows the aic7xxx module is "initializing". This happens whether I use a
driver floppy or not. Same result in expert, text or gui mode.

The aic7xxx module is stuffed ...
Comment 27 Doug Ledford 2001-04-17 00:42:06 EDT
markgw@sgi.com, boot the system with the command linux noprobe, then when
prompted for any drivers you wish to load, select SCSI, then select New Adaptec
... driver instead of the standard Adaptec SCSI driver and see if that doesn't
solve your problem (which is obviously different from the problem in this thread
despite the similar subject lines since the problem in this thread has worked
its way down to being dependant on CD-ROM to IDE connection issues).
Comment 28 Mark Goodwin 2001-04-17 01:06:59 EDT
Booted seawolf CD1 with expert noprobe .. chose the new experimental aic7xxx
driver, but it still hangs. 

The ALT-F2 console shell is alive and lsmod shows:
   aic7xxx_mod: (initializing)

The ALT-F4 console shows the driver is walking scsi id 's, getting 
errors and timeouts like the following:

<4> scsi0:0:11:0: Attempting to queue a TARGET RESET message
<4> scsi0:0:11:0: Attempting to queue an ABORT message
<4> aic7xxx_abort returns 8194
<6> scsi: device set offline - not ready or command retry failed after bus
reset: ...

then it tries the next scsi id. When it gets to 15, goes back to zero.
I know the controller is good and the disk is good. The scsi bios is 
set to defaults.

Interestingly, the same thing happened on my home system with adaptech 1542
using wolverine. I will try seawolf tonight ...
Comment 29 Doug Ledford 2001-04-19 19:49:45 EDT
To markgw:  Since your problems appears with either of the aic7xxx drivers, it
likely isn't an aic7xxx issue, but something like an interrupt issue (it's
acting like the install kernel is screwing up interrupt routing and the aic7xxx
driver is never getting the interrupts it should as a result).  Since this is
wildly different than the original posters bug, please open a different bug
report mentioning that neither aic7xxx driver works on your machine and listing
some details.  Of interest would be the contents of /proc/interrupts on your
machine with an install kernel and with a working kernel.

To the original reporter, I'm changing to topic of this bug to reflect what
you've found and assigning it to Arjan, who knows more about IDE stuff than I do
(I suspect the answer to your problem is to use the idebus= option to get the
right speed and make the CD work, but I don't know how that will effect the IDE
interfaces on the Promise controller so I'm hesitant to tell you to use it).
Comment 30 Arjan van de Ven 2001-04-20 04:33:48 EDT
pwatkins@retaillabs.com: please try booting with "ide=nodma" as options to the
lilo prompt. If that fixes the problem, please give the output of
"cat /proc/ide/hdc/model" so we can make this the default for this drive.
Comment 31 Paul Watkins 2001-04-25 23:29:56 EDT
Per your last comments: RH boots fine with both cd's in the system.  The problem
is during the install only.  As stated earlier in the bugzilla dialogs, it
happened during the install of Fisher and then Wolverine.  I got around the
problem by disconnecting the data cable from the cd-RW and installing the cd
from the cd-rom drive.  After the install was completed I reconnected the data
cable to the cd-rw and the system correctly itentified and installed the drivers
and all has been well.  I installed all the wolverine beta updates with no
problems and the reboots periodically during the process were fine.

I just tried to install seawolf from cd's and the same problem occurs as with
the betas -- system hangs and needs to be rebooted using the hardware (switches
or hardware restart).  I removed the data cable from the cd-rw and seawolf
installed fine and everything is working well now including reboots .

So your suggestion about adding a statement to lilo doesn't seem to be apropos
here since this problem is with the installation.l
Comment 32 Jean-Luc Richier 2001-05-28 07:59:42 EDT
I just have the hang problem with RedHat7.1 (Seawolf), and the boot option
ide=nodma solved it
My cdrom type is:
::::::::::::::
/proc/ide/hdb/model
::::::::::::::
CD-ROM CDU701
Comment 33 Bugzilla owner 2004-09-30 11:38:55 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.