This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29305 - gated doesn't support pim or igmp
gated doesn't support pim or igmp
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: gated (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 17:58 EST by Tim Clymo
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-02-24 17:58:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.23 i686)


According to the documentation in
/usr/share/doc/gated-3.6/doc/config_guide/samp_mcast.html it should be
possible to get gated to support multicast routing protocols such as pim
and igmp.

In the simplest possible case, I create /etc/gated.conf containing 2 lines:
pim yes;
igmp yes;

However, when I run /usr/sbin/gated it dies. There is a syslog entry in
/var/log/messages indicating that both lines in the config have failed to
be parsed

Reproducible: Always
Steps to Reproduce:
1. See description
	

Actual Results:  It died

Expected Results:  Should have started talking pim and igmp

/etc/gated.conf:
pim yes;
igmp yes;

/var/log/messages:
Feb 24 22:47:41 tcpc gated[2414]: Start gated[2414] version
gated-public-3_6 built Tue Jan 23 23:03:29 EST 2001
Feb 24 22:47:41 tcpc gated[2414]: parse: gated.conf:1 parse error at 'pim'
length 3
Feb 24 22:47:41 tcpc gated[2414]: parse: gated.conf:2 parse error at 'igmp'
length 4
Feb 24 22:47:41 tcpc gated[2414]: parse_parse: 2 parse errors
Feb 24 22:47:41 tcpc gated[2414]: Exit gated: ^I^IVersion gated-public-3_6
built Tue Jan 23 23:03:29 EST 2001 ^I^IPid 2414, started Sat Feb 24
22:47:41 2001
Comment 1 Nalin Dahyabhai 2001-02-28 17:31:32 EST
It appears that the public version doesn't support PIM or IGMP, and links to the
sample file you're looking at have been removed from
/usr/share/doc/gated-3.6/doc/config_guide/statements.html, presumably for this
reason.  This also appears to be the case for the dvmrp and routerdiscovery
statements.  I can remove those files from the package to make it more
consistent, but since we don't have the sources for the igmp and pim modules,
there's not much more that can be done.
Comment 2 Bill Nottingham 2006-08-07 15:36:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 12:54:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.