Bug 293061 - Cowsay doesn't let Getopt::Std support --help correctly.
Cowsay doesn't let Getopt::Std support --help correctly.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cowsay (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-17 07:36 EDT by Lubomir Kundrak
Modified: 2009-01-07 13:09 EST (History)
0 users

See Also:
Fixed In Version: 3.03-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (1.84 KB, patch)
2007-09-17 07:40 EDT, Lubomir Kundrak
no flags Details | Diff

  None (edit)
Description Lubomir Kundrak 2007-09-17 07:36:00 EDT
Description of problem:

Cowsay doesn't let Getopt::Std support --help correctly.

Version-Release number of selected component (if applicable):

cowsay-3.03-2.fc7

Steps to Reproduce:
1. cowsay --help
  
Actual results:

$ cowsay --help
/usr/bin/cowsay version [unknown] calling Getopt::Std::getopts (version 1.05
[paranoid]),
running under Perl version 5.8.8.

Usage: cowsay [-OPTIONS [-MORE_OPTIONS]] [--] [PROGRAM_ARG1 ...]

The following single-character options are accepted:
        With arguments: -e -f -T -W
        Boolean (without arguments): -b -d -g -h -l -L -n -N -p -s -t -w -y

Options may be merged together.  -- stops processing of options.
Space is not required between options and their arguments.
  [Now continuing due to backward compatibility and excessive paranoia.
   See ``perldoc Getopt::Std'' about $Getopt::Std::STANDARD_HELP_VERSION.]
^C
$

Expected results:

cow{say,think} version 3.03, (c) 1999 Tony Monroe
Usage: cowsay [-bdgpstwy] [-h] [-e eyes] [-f cowfile] 
          [-l] [-n] [-T tongue] [-W wrapcolumn] [message]
Comment 1 Lubomir Kundrak 2007-09-17 07:40:54 EDT
Created attachment 197261 [details]
Fix

Patch commited to rawhide.
Comment 2 Fedora Update System 2007-10-10 21:46:02 EDT
cowsay-3.03-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cowsay'
Comment 3 Fedora Update System 2007-10-24 03:15:14 EDT
cowsay-3.03-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.