Bug 29375 - [RFE] make isdnlog more configurable
Summary: [RFE] make isdnlog more configurable
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-25 12:30 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 12:30:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-02-25 12:30:33 UTC
/etc/init.d/isdn:466 calls isdnlog with static options. Because (newer)
isdn4k-utils can e.g. set hangup-behavior (hangup=...-option),
timesetting-behavior (time=...) or different logging-option for
error-tracking, a lot of users will want to call isdnlog with their own
options.

Currently this needs to edit /etc/init.d/isdn.

Because isndlog can read its configuration from files (the -f ... switch) I
suggest to ship the internet-config package with a config-file (e.g.
/etc/isdn/isdnlog.options) and call isdnlog with '-f <filename>':

|  daemon isdnlog /dev/isdnctrl0 -D -f /etc/isdn/isdnlog.options

Comment 1 Ngo Than 2001-02-26 11:10:00 UTC
i have changed isdn script so that it first checks /etc/isdn/isdnlog.option if
that file
exists. It call isdnlog with '-f <filename>' if this file exists otherwise
statisch options.



Note You need to log in before you can comment on or make changes to this bug.