Bug 29376 - Special chars in username not handled properly
Summary: Special chars in username not handled properly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-25 12:30 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 12:33:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-02-25 12:30:44 UTC
When having an username with an '#' (e.g. the German T-Online ISP has such
names) it will be put into the secret-file without quoting.

Because ipppd interprets '#' as comment-sign all information behind it will
be ignored and authentification will fail.

I suggest to quote the name in /etc/init.d/isdn:178 (and below in current
rawhide):

-                create_option_file "user \"$USER\"" "$1"
+                create_option_file "user $USER" "$1"

Comment 1 Enrico Scholz 2001-02-25 12:33:04 UTC
Uups; diff-output swapped...

Comment 2 Ngo Than 2001-02-26 09:57:45 UTC
It's fixed with internet-config-0.33-1. Thanks.


Note You need to log in before you can comment on or make changes to this bug.