Bug 2938 - redhat 6.0 spontaneously reboots while idle
redhat 6.0 spontaneously reboots while idle
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-20 13:05 EDT by sand
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-16 11:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sand 1999-05-20 13:05:48 EDT
i'm just guessing (as your website suggested) about the
component.

i walk away from redhat (running gnome) for, oh, five or ten
minutes; and when i get back, redhat is rebooting. i set the
screensaver to a huge number (120, 600 or 6000), same
behavior. i searched for core files and found:

/core --- from 'gmc --sm-client-id default10' (signal 11)
/root/core -- from 'mw-capplet-properties --sync --id=2
--ixd=50331779' (signal 6)

neither of these is dated recently enough to be related. my
next step is to rebuild the kernel. any suggestions would be
greatly appreciated. btw, redhat 5.2 worked GREAT, never
rebooted, stayed up for months at a time.
Comment 1 Derek Tattersall 1999-05-20 13:33:59 EDT
Please give your hardware listing, and what you installed.  Have you
checked for bad memory?
Comment 2 sand 1999-05-21 16:23:59 EDT
VS440FX intel motherboard, adaptec 2940 ultra wide scsi host adapter,
4gb hd, toshiba cdrom, microsoft ps/2 mouse, stealth 64 graphics card,
3com 3c509b-tpo etherlink III card, 64 mb ram.

I have not checked for bad memory; how do i do that?

also, i recompiled the kernel and it panics, thinking that i have two
scsi host adapters, which i don't. i'll try recompiling it tomorrow.
Comment 3 sand 1999-05-24 14:26:59 EDT
i've figured out how to fix this problem: i recompiled the kernel for
386 (rather than for the processor that i have: 686), turning off both
advanced power management and watchdog timer support for character
devices. i have not narrowed this down any further to determine with
absolute certainty which one of these three is causing the problem; but
i tried compiling the kernel for 686 with APM and watchdog off, and the
problem remained. hope this helps you all. :)
Comment 4 Cristian Gafton 1999-06-16 11:15:59 EDT
maybe this is something that Alan should take a look at. For now, we
can't reproduce it here.

Note You need to log in before you can comment on or make changes to this bug.