Bug 29385 - Segmentation fault in rpm 4.0-4 in transaction.c # 802
Segmentation fault in rpm 4.0-4 in transaction.c # 802
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 09:11 EST by mbosch
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 10:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mbosch 2001-02-25 09:11:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; 0.7)
Gecko/20010126


I've been trying to use RedCarpet from Ximian for the past week. However,
it never succeeds to install the packages it downloads because rpm crashes
on most of the rpm's it downloads. This also happens with the rpm-4.0-4 it
downloads, so I can not upgrade to a working rpm.
Therefor I have compiled rpm myself from the source rpm-4.0-4 src rpm.
Also this crashes, however, now I can use gdb.
It crashes in transaction.c at line 802 because otherStates = 0.

Note that approximately half of the rpm files I downloaded recently do not
crash and half of them do. I have no clue why otherStates ==0, but if you
need more information, or you can not reproduce, I can play some more with gdb.

greetings

Marco Bosch

Reproducible: Always
Steps to Reproduce:
1.download for instance GConf-0.12-100_helix_2001020808.i386.rpm2.
2.su (become root)
3.rpm -Uvvh GConf-0.12-100_helix_2001020808.i386.rpm

	
Actual Results:  Segmentation fault

Expected Results:  No crash, but installation of the package

output just before segfault

D: installing binary packages
D: getting list of mounted filesystems
D: opening db index       /var/lib/rpm/Group create mode=0x42
D: opening db index       /var/lib/rpm/Triggername create mode=0x42
Comment 1 Jeff Johnson 2001-02-25 09:23:26 EST
Um, try the rpm-4.0.2 packages at
	ftp://ftp.rpm.org/pub/rpm/test-4.0.2
as there are several known miscompilations of rpm with gcc-2.96

Meanwhile, you probably have packages in your database that are
missing the file states tag. That will cause segfaults, but never should
have happened, and how you got into that state needs to be understood.
I can tell you how to work around, but I need to be on the same sources
as you to tell you what will be needed.
Comment 2 mbosch 2001-02-25 09:35:16 EST
It's not really a big problem, I will reinstall Red Hat 7.0 and try to
see if it works ok. However, I've done this already yesterday, and the only
packages I've installed afterwards where the one that Red Carpet tried to
download and install.
And the first one is rpm-4.0-4. And sometime after that, I got into problems...


Marco
Comment 3 Jeff Johnson 2001-04-05 08:51:08 EDT
This problem is both caused and fixed by rpm-4.0.2. Install that version.

Note You need to log in before you can comment on or make changes to this bug.