Bug 29387 - rpm-python doesn't work with python 2.0
Summary: rpm-python doesn't work with python 2.0
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-25 14:28 UTC by mbosch
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 14:28:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mbosch 2001-02-25 14:28:16 UTC
The rpm sources contain a directory python, which contains
the sources for rpmmodule. This allows python programs to
use rpmlib.
However, it only works with python 1.5
This was ok for a long time since the development cycle for
python was very slow. However, in the last year or so, there
has already been version 1.6, 2.0 and now 2.1.
The problem is that the paths /usr/lib/python1.5/site-packages
and /usr/include/python1.5 are hardcoded in Makefile.am
These paths should be determined by a configure script.
One way to determine the path for the site-package is something
along the lines of:

#!/usr/bin/env python
import sys,string
for path in sys.path:
    if string.find(path,"site-packages")==len(path)-13: print path
print sys.executable

(There might be easier ways)


greetings,

Marco Bosch

Comment 1 Jeff Johnson 2001-02-25 14:39:09 UTC
Red Hat ships with Python 1.5.2, all the usual adornments to the build will
happen if/when
we convert to Python-2.0

Meanwhile, AFAIK, the changes are very straightforward, although I have no idea
whether Python-2.0 "works" as I've never looked.


Note You need to log in before you can comment on or make changes to this bug.