Bug 294071 - missing dependency: libavahi-ui.so.0:
missing dependency: libavahi-ui.so.0:
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-17 19:11 EDT by Stuart Jansen
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 10:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.log (18.86 KB, text/plain)
2007-09-17 20:10 EDT, Stuart Jansen
no flags Details
yum.log after a new install of f8t2 (23.38 KB, text/plain)
2007-09-22 22:22 EDT, Stuart Jansen
no flags Details

  None (edit)
Description Stuart Jansen 2007-09-17 19:11:00 EDT
Description of problem:
$ vinagre 
vinagre: error while loading shared libraries: libavahi-ui.so.0: cannot open
shared object file: No such file or directory


Version-Release number of selected component (if applicable):
$ rpm -q vinagre
vinagre-0.2-1.fc8

$ yum install -y avahi-ui
$ vinagre
(works)
Comment 1 Bastien Nocera 2007-09-17 19:23:13 EDT
How did you install vinagre? Which exact version of vinagre and which
architecture were you using?

It should have complained of the needed deps, so either the rpm package itself
is missing it (in which case that's a build problem), or yum/whatever you used
to install it is broken.
Comment 2 Stuart Jansen 2007-09-17 19:29:03 EDT
/me points at the rpm -q above for the version

vinagre-0.2-1.fc8 on i386 Fedora 8 test 2 yum updated to the latest available
packages.

As for the install command:
yum install vinagre
Comment 3 Bastien Nocera 2007-09-17 19:40:25 EDT
$ rpm -qp --requires vinagre-0.2-1.fc8.i386.rpm | grep avahi
libavahi-client.so.3  
libavahi-common.so.3  
libavahi-glib.so.1  
libavahi-ui.so.0  

yum's fault.
Comment 4 Jeremy Katz 2007-09-17 19:57:52 EDT
Do you know what version of yum you had installed when you installed vinagre? 
Actually, if you attach /var/log/yum.log, we should be able to figure that   
Comment 5 Stuart Jansen 2007-09-17 20:10:46 EDT
Created attachment 197941 [details]
yum.log
Comment 6 Seth Vidal 2007-09-17 21:26:48 EDT
Stuart,
 Can you still make this happen? If you remove avahi-ui and vinagre does it
still happen?
Comment 7 Stuart Jansen 2007-09-18 12:07:48 EDT
Nope, can't reproduce with latest packages.
Comment 8 Stuart Jansen 2007-09-22 22:21:41 EDT
I recently noticed a similar problem when using pirut to install conglomerate on
F7. I did a fresh install of F8t2 and yum updated it to current as of 22 Sep
2007, the used pirut to install or remove a number of packages. Afterwards, I
checked to see if I experienced the same problem. I did, and interestingly it
involved similar packages. Oddly, pirut claimed it was going to install avahi-ui
and gtk-vnc but it looks like it didn't actually.

I will also be attaching a copy of /var/log/yum.log

# rpm -Va --nodigest --nofiles --noscripts --nosignature --nolinkto --nomd5
--nosize --nouser --nogroup --nomtime --nomode --nordev
Unsatisfied dependencies for conglomerate-0.9.1-4.fc8.i386:
libgtksourceview-1.0.so.0
Unsatisfied dependencies for rpm-build-4.4.2.2-0.5.rc2.i386: elfutils >= 0.128
Unsatisfied dependencies for istanbul-0.2.2-4.fc8.i386: gstreamer-python,
python-xlib
Unsatisfied dependencies for vinagre-0.2-1.fc8.i386: libavahi-ui.so.0,
libgtk-vnc-1.0.so.0
Unsatisfied dependencies for seahorse-1.0.1-9.fc8.i386: libgpgme.so.11,
libgpgme.so.11(GPGME_1.0)
Comment 9 Stuart Jansen 2007-09-22 22:22:41 EDT
Created attachment 203301 [details]
yum.log after a new install of f8t2
Comment 10 Stuart Jansen 2007-09-22 22:31:18 EDT
I tried removing avahi-ui and gtk-vnc then using pirut to reinstall vinagre.
This time pirut did correctly install avahi-ui and gtk-vnc. Perhaps the bug can
only be triggered when using pirut to install and remove several packages at the
same time.
Comment 11 Jeremy Katz 2007-10-12 10:07:35 EDT
With some trying here, I can't reproduce this.  Given that we've made some fixes
in depsolving which could have led to this, I'm going to go on the theory that
we got it fixed up.

Note You need to log in before you can comment on or make changes to this bug.