Bug 294531 - The default console font does not include the romanian diacritics
The default console font does not include the romanian diacritics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Liang Zhang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 329071
  Show dependency treegraph
 
Reported: 2007-09-18 07:15 EDT by Alexandru Szasz
Modified: 2015-04-06 23:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 21:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandru Szasz 2007-09-18 07:15:53 EDT
Description of problem:

Also MAYBE related to kbd component:

The default console font (latarcyrheb-sun16 in Fedora) does not
include all the characters needed to display correctly the romanian
language.

Characters șțȘȚ (s,t with comma) and ” (right double quotation mark) are not
available in latarcyrheb-sun16.

I found that LatArCyrHeb-16.psfu DOES have them. Is it possible to associate a
font with a keymap or language?


Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Load the romanian keymap presented in bug 292091
2. Run "setfont latarcyrheb-sun16"
3. Type Altgr+s, Alt gr+t, Altgr + ]
  
Actual results:

Wrong symbols are displayed. Instead of the right double quotation mark (Altgr +
]) there's a simple quotation mark displayed. Similar but not equal.

Expected results:

The correct characters should be displayed

Additional info:

If you follow the steps :
1. Load the romanian keymap presented in bug 292091
2. Run "setfont LatArCyrHeb-16"
3. Type Altgr+s, Alt gr+t, Altgr + ]

everything is ok, so I guess this can be fixed only if there is a possibility to
change the console font when changing the keymap (e.g lang=ro in kernel command
line)

Another solution may be to modify the font latarcyrheb-sun16. Tell me if it's
possible, I can give the details to who's in charge of that.

If this association or change is not possible, please say what can be done even
if not right now.
Comment 1 Vitezslav Crhonek 2007-09-24 06:52:40 EDT
I've changed component to anaconda, because this is not kbd bug. BTW
latarcyrheb-sun16 does have s, S, t, T with comma below, it only doesn't have
this specific double quotation mark. Maybe you have to fill another bug against
system-config-language, but I'm definitely not sure.
Comment 2 Alexandru Szasz 2007-09-24 07:55:47 EDT
I found that system-config-language could fix this by changing the "locale-list"
file from system-config-language sources:

Line 
    ro_RO.UTF-8 utf8 latarcyrheb-sun16 Romanian 
should be changed to
    ro_RO.UTF-8 utf8 LatArCyrHeb-16 Romanian

Of course, this only if the LatArCyrHeb-16 font is here to stay and will not be
removed in the future.

I am not sure if this would set the font to LatArCyrHeb-16 in console during
anaconda installation as well.
Comment 3 Chris Lumens 2007-10-02 17:05:55 EDT
anaconda has its own list that is similar to the one in system-config-language.
 I'll fix that up in anaconda and reassign this one to the correct owner since
it's still set to anaconda-maint-list.
Comment 4 Liang Zhang 2007-10-09 02:03:34 EDT
I fixed this bug in system-config-language-1.2.12.
Comment 5 Rahul Sundaram 2007-10-28 21:20:33 EDT
Closing this bug report. Feel free to reopen if any issues persist. 

Note You need to log in before you can comment on or make changes to this bug.