Bug 29471 - -Wp,-MD is broken
-Wp,-MD is broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 18:24 EST by Brian Ryner
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 16:32:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2001-02-25 18:24:56 EST
I'm noticing this in my Mozilla build, which uses -Wp,-MD,.deps/filename.pp
to track dependencies.  If I touch a header file, the source files which
include it do NOT get rebuilt as they should.  This broke sometime since
-69.  I can provide the generated dependency files if that would help.
Comment 1 Jakub Jelinek 2001-02-26 05:41:40 EST
There is just one issue I'm aware: the goal in the dependency file has full
pathname in front of it instead of just basename.o. This should be fixed in
cpp-2.96-76, but there is one gcc driver bug in that version which will be fixed
in gcc-2.96-77. Can you check if that is the reason why dependencies don't work
right for you (ie. can you replace /some/strange/path.o: some dependencies
with path.o: some dependencies in the .pp files?).
Comment 2 Brian Ryner 2001-02-26 16:32:24 EST
I haven't had a chance to check it for sure yet, but this sounds like it's the
problem.  I am building in a separate object dir, and the path to the .o in the
.pp file is actually the path to the source file with .cpp changed to .o, so it
was referencing the wrong location.
Comment 3 Brian Ryner 2001-03-06 16:38:15 EST
This is fixed now.

Note You need to log in before you can comment on or make changes to this bug.