Bug 294841 - alsa-lib has a configure bug which causes it not to build the lfloat plugin
Summary: alsa-lib has a configure bug which causes it not to build the lfloat plugin
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-18 15:05 UTC by John (J5) Palmieri
Modified: 2013-03-13 04:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 09:43:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build the lfloat plugin (300 bytes, text/x-patch)
2007-09-18 15:05 UTC, John (J5) Palmieri
no flags Details

Description John (J5) Palmieri 2007-09-18 15:05:32 UTC
Description of problem:

The lfloat plugin is used by csound and other sound applications when talking to
alsa.  Since version 1.0.14 a conditional was added to the configure scripts
which turns off the lfloat plugin.  A simple configure patch should fix this. 
We need this for OLPC and I felt it was not worth forking the package just to
get this bug fix in.  For now I did a scratch build but we should be getting
this from F7.

This is fixed in 1.0.15a but I have attached a patch which also fixes the issue
with the current release without being invasive.

Also an issue with rawhide

Relevant discussions at http://dev.laptop.org/ticket/3519

Version-Release number of selected component (if applicable):

1.0.14-1

Comment 1 John (J5) Palmieri 2007-09-18 15:05:32 UTC
Created attachment 198451 [details]
build the lfloat plugin

Comment 2 Martin Stransky 2007-09-19 09:43:06 UTC
added to package alsa-lib-1.0.14-4.fc7


Note You need to log in before you can comment on or make changes to this bug.