Bug 29486 - Anaconda installer bails out on large partition sizes
Summary: Anaconda installer bails out on large partition sizes
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-25 23:39 UTC by Peter Bennison
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 00:44:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bennison 2001-02-25 23:39:08 UTC
Hello,

I was trying to custom install Red Hat 7.0 professional with two 
partitions on a 30 Gig hard drive: /boot (19 Megs) / (the rest of the 
HD).  The install process fails with an error message (below).

Okay, the partitions are not exactly standard, but I didn't see anything 
in the documentation barring large partitions.  Also, I wanted to avoid 
running out of disk space on any one partition when other partitions have 
space available.

The work around was to install a server solution and allow it to 
automatically partition the disk.  Then, I went back and redid a custom 
solution, accepting the partitions that were created in the first 
install.  Dumb, I know, but it worked.  I hope that I don't run out of 
disk space on some of the partitions.  

Here's the bug report that was produced:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 26483121
fsystem: ext2
self: <fstab.GuiFstab instance at 84bae20>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda6
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-02-26 04:12:09 UTC
It looks like from the dump you chose not to format the '/' partition.

This will definately cause problems, and something we've added checks for in
newer versions of the installer.

Does this sound like what happened?

Comment 2 Peter Bennison 2001-02-26 06:14:11 UTC
I don't believe so, but, then again, it was a bit late!  I'm pretty sure I 
elected to format all partitions.


Comment 3 Michael Fulbright 2001-02-28 00:03:52 UTC
If you could try again I would appreciate it. The doFormat = 0 in the dump means
it was not going to try and format the partition.

Comment 4 Peter Bennison 2001-02-28 00:44:12 UTC
I appreciate you trying to solve this, but I already have invested a bit of 
time setting up my Linux box.  Like I said in my original report, I was able to 
work around the problem.  Unless you can tell me how to do a re-install, but 
not overwrite my existing set-up, I can't help you.

Thanks anyways,

P.

Comment 5 Michael Fulbright 2001-02-28 15:23:21 UTC
Ok please open a new report if you have any future problems.


Note You need to log in before you can comment on or make changes to this bug.