Bug 29489 - Install kernel hangs on Cyrix MII processor
Summary: Install kernel hangs on Cyrix MII processor
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-26 00:21 UTC by Nicko van Someren
Modified: 2007-04-18 16:31 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-26 00:21:46 UTC


Attachments (Terms of Use)

Description Nicko van Someren 2001-02-26 00:21:41 UTC
The ssystem is an old eMachines desktop PC with a Cyrix MII/266 processor.

Using the 7.0.91 Beta ISO images the machine loads kernel just fine but
just after the memory information line I get the message:

Checking if this processor honours the WP bit even in supervisor mode...

and the system then hangs.  This seems to come from the kernel source file
arch/i386/mm/init.c but I do not profess to know any more than that; it's
not a bit of the kernel I've ever looked at.  Suffice it to say it looks
like RedHat 7.1 will not boot on old Cyrix machines as it stands.

Comment 1 Arjan van de Ven 2001-02-26 09:58:51 UTC
This problem manifested itself also for some 486's. It was caused by a 
fix for an SMP race in vmalloc which broke the "WP" test for several older CPU 
types. A fix for this breakage will be in the next kernel we build.


Note You need to log in before you can comment on or make changes to this bug.