Bug 29493 - running up2date through sshd, kills sshd when updateing
Summary: running up2date through sshd, kills sshd when updateing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-26 00:39 UTC by Rod m. Stewart
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 23:31:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rod m. Stewart 2001-02-26 00:39:40 UTC
If you run 'up2date --nox -u' from remote through an sshd connection, your
connection dies when it updates the openssh-server rpm.  At least going
from fisher to wolverine it does.   This would seem to me to be something
many people would do, as I don't usually want to log onto the console of
every machine I have to run up2date.

One other thing I noticed was that sshd did not restart, I had to go
upstairs and restart it on the server manually.

Not certain if this is up2date or openssh related.

Comment 1 Glen Foster 2001-02-26 23:50:29 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #2

Comment 2 Adrian Likins 2001-02-27 20:42:56 UTC
Isnt this an issue with the openssh packages? Shouldnt they
be handling the "update" themselves?  

I dont  know anything that up2date would be doing, or
could be doing to prevent this.

Comment 3 Preston Brown 2001-02-27 23:31:51 UTC
this is an openssh issue, but I don't know if it can be changed.

Comment 4 Nalin Dahyabhai 2001-02-28 16:27:12 UTC
IIRC this was due to some changes in the way initscripts would restart
services.  I believe that this is fixed in the current tree (I have
experimentally verified this, too).  Please reopen this bug if you find that
this continues to be a problem with initscripts-5.65 and later.


Note You need to log in before you can comment on or make changes to this bug.