Bug 29498 - Installer runs LILO without asking for permission
Installer runs LILO without asking for permission
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
: 29729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 21:23 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 19:43:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-25 21:23:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.5-15smp i586)


Notebook install, but with 'select packages'...  after install, LILO had
been run, without 
asking if I wanted it.  (I didn't of course.  ;)

Reproducible: Didn't try
Steps to Reproduce:
1. notebook install
2. select individual packages (don't know if this is necessary.)
3. complete installation.
	

Actual Results:  My notebook needs lba32, so it wouldn't boot.  

Expected Results:  When asked if I wanted to install a bootstrap loader,
I'd say no, and it would leave things alone, so I could go in with the
existing (other) boot and fix things up.

'linear' doesn't work w/  my notebook (Toshiba Satellite 330CDT), the hard
disk is about 20GB.
Comment 1 Michael Fulbright 2001-02-25 23:10:08 EST
Did you choose automatic or manual partitioning?

May be related to bug 29502.
Comment 2 Need Real Name 2001-02-26 07:34:04 EST
I chose manual partitioning;  (The machine was already partitioned, w/ several
other installations of Linux on it.)  It ran the druid, and I selected the mount
points.  The wolverine seems to have left the other partitions alone.
Comment 3 Glen Foster 2001-02-26 18:57:19 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 sandy 2001-02-27 16:38:05 EST
Yes, please always add a lilo config option during install.

I've already complained about this type of behaviour.
Comment 5 Preston Brown 2001-02-27 18:41:40 EST
*** Bug 29729 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2001-02-27 19:43:13 EST
There is a check-box around the time that discs are partitioned saying "install 
lilo" -- this is checked by default. Perhaps this is the issue?
Comment 7 Erik Troan 2001-02-28 16:34:14 EST
You can control lilo installation on all types of installs.
Comment 8 Need Real Name 2001-02-28 20:17:02 EST
I was warned before I overwrote the target partitions, but not when I zapped the
bootstrap loader.
If not a bug, it's still poor design to be inconsistent in this way with
irreversible system changes.
Anyhow, thanks for your time.  The new product is looking nice.

Note You need to log in before you can comment on or make changes to this bug.