This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29500 - Static routes for aliased interfaces in RH7.0 no longer work
Static routes for aliased interfaces in RH7.0 no longer work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 21:34 EST by John Bass
Modified: 2014-03-16 22:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 05:34:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to /etc/sysconfig/network-scripts/ifup-aliases to correct static routes (631 bytes, patch)
2001-03-05 05:34 EST, chris
no flags Details | Diff

  None (edit)
Description John Bass 2001-02-25 21:34:24 EST
After upgrading from RH6.x to RH7.0 static routes for aliased interfaces
are no longer applied at boot time, or when the interfaces are manually
started/stopped with ifup/ifdown.
Comment 1 chris 2001-03-05 05:33:06 EST
This seems to be caused by a bug in /etc/sysconfig/network-scripts/ifup-aliases
which looks for static routes via the parent interface instead of the aliased
one.  I think the attached patch fixes.
Comment 2 chris 2001-03-05 05:34:24 EST
Created attachment 11782 [details]
Patch to /etc/sysconfig/network-scripts/ifup-aliases to correct static routes
Comment 3 Bill Nottingham 2001-03-05 12:27:31 EST
Will be fixed in 5.70-1; thanks!
Comment 4 chris 2001-05-22 05:20:03 EDT
It looks like this still hasn't been fixed in the initscripts-5.83-1 which comes
with RH7.1, or the initscripts-5.86-1 currently in RawHide.

Thanks,
Chris.
Comment 5 Bill Nottingham 2001-05-22 16:19:19 EDT
In what way?  The code is changed as described above.

Do note, support for *incorrectly formed* static route entries
(as linuxconf has generated in the past) was dropped.
Comment 6 chris 2001-05-23 05:00:01 EDT
No, it isn't.  In 5.83-1, line 278 of ifup-aliases says:

  grep "^$1 " /etc/sysconfig/static-routes | while read device args; do

It hasn't been patched.  If it had, it would say:

  grep "^$DEVICE " /etc/sysconfig/static-routes | while read device args; do
Comment 7 Bill Nottingham 2001-05-23 10:17:29 EDT
Aack, you're right. Sorry about that.
This will get fixed in 5.88-1.

Note You need to log in before you can comment on or make changes to this bug.