Bug 29527 - Toshiba Laptop Sound Problem
Toshiba Laptop Sound Problem
Status: CLOSED DUPLICATE of bug 25085
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 03:39 EST by worldwideweber
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 08:11:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description worldwideweber 2001-02-26 03:39:37 EST
sndconfig can no longer configure the sound on Toshiba laptop 
(Toshiba Satellite 225 CDS w/ Yamaha sound system).

I can load the opl3sa2 module, but I keep getting errors 
reporting problems reading /dev/audio.
Comment 1 Bill Nottingham 2001-02-26 07:58:57 EST
What does your /etc/modules.conf look like?
Comment 2 worldwideweber 2001-02-26 10:27:37 EST
--- modules.conf ---

alias sound-slot-0 opl3sa2
options sound dmabuf=1
alias midi opl3
options opl3 io=0x388
options opl3sa2 mss_io=0x530 irq=5 dma=1 dma2=0 mpu_io=0x330 io=0x370
Comment 3 Bill Nottingham 2001-02-26 11:22:13 EST
What happens if you add 'isapnp=0' to the end of the 'options' line?
Comment 4 worldwideweber 2001-02-26 12:47:43 EST
The driver complains that isapnp is an invalid parameter.

---- SNIP ----
/sbin/insmod opl3sa2 mss_io=0x530 irq=5 dma=1 dma2=0 mpu_io=0x330 io=0x370
isapnp=0
Using /lib/modules/2.4.2/kernel/drivers/sound/opl3sa2.o
/lib/modules/2.4.2/kernel/drivers/sound/opl3sa2.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
Comment 5 Bill Nottingham 2001-02-26 12:55:37 EST
It's not an invalid parameter, it just didn't find the card where you
told it it was.

What happens if you remove the 'options' line and just do

modprobe opl3sa2 isapnp=1

?
Comment 6 worldwideweber 2001-02-26 13:07:10 EST
Nothing that I can see happens when I run modprobe.  The module is loaded but
sound still doesn't work.

(me) /usr/src/linux -> /sbin/modprobe opl3sa2 isapnp=1
Note: /etc/modules.conf is more recent than /lib/modules/2.4.2/modules.dep
(me) /usr/src/linux -> /sbin/lsmod                    
Module                  Size  Used by
opl3sa2                 7472   0  (unused)
ad1848                 17360   0  [opl3sa2]
mpu401                 19152   0  [opl3sa2]
sound                  57488   0  [opl3sa2 ad1848 mpu401]
soundcore               3824   2  [sound]
Comment 7 Bill Nottingham 2001-02-26 13:16:32 EST
Well, it loads the module, which is a start.

What does 'dmesg' say?
Comment 8 worldwideweber 2001-02-26 13:30:16 EST
dmesg says that it can't find a card.

opl3sa2: No cards found
opl3sa2: 0 PnP card(s) found.

Something interesting (also yelled by dmesg):

opl3sa2: Control I/O port 0x0 not free

I think this latter message is from when I tried to set the io,irq, etc
manually, but interesting nonetheless.
Comment 9 Bill Nottingham 2001-02-26 13:33:48 EST
Is it a PnP card?

Is there anything in /proc/isapnp?

Are you *sure* all the parameters are correct?
Comment 10 worldwideweber 2001-02-26 13:47:00 EST
The detailed specs from Toshiba don't say whether the card (or bus) is PnP.  
I would guess that it is not... this is an old Toshiba Satellite 225 CDS
(Pentium 133 MHz).

There is no /proc/isapnp.

As for the paramters I use, they are exactly the same as the parameters I used
under RedHat 6.x.
Comment 11 Bill Nottingham 2001-02-26 15:20:40 EST
What does 'cat /proc/ioports' say?
Comment 12 worldwideweber 2001-02-26 20:03:14 EST
(me) ~ -> more /proc/ioports 
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
02f8-02ff : serial(set)
0300-031f : 3c574_cs
0378-037a : parport0
03c0-03df : vga+
03e0-03e1 : i82365
03e8-03ef : serial(auto)
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0cf8-0cff : PCI conf1
Comment 13 worldwideweber 2001-03-01 08:11:28 EST
Fixed in kernel 2.4.2-ac7.
Comment 14 worldwideweber 2001-03-01 08:15:58 EST

*** This bug has been marked as a duplicate of 25085 ***

Note You need to log in before you can comment on or make changes to this bug.