Bug 29530 - installer incorrectly uses obsolete device drivers for 2-head Matrox Millenium G450 video card
installer incorrectly uses obsolete device drivers for 2-head Matrox Milleniu...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 04:53 EST by Erich Schwarz
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 02:14:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Schwarz 2001-02-26 04:53:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)


   On installing wolverine, the installer confidently auto-detects a 2-head
Matrox G450 video card as "Matrox G400".  Then when I later try to set up X
windowing, the entire system hangs completely (cannot be cleanly rebooted
with three-finger salute).  I have observed this problem on two machines
(same hardware, installer CD).  I have checked the matrox.com Web site and
found that they are offering up-to-date device drivers for their 2-headed
Matrox G450 card, at:
http://www.matrox.com/mga/support/drivers/latest/home.cfm


Reproducible: Always
Steps to Reproduce:
1. get machine with Matrox Millenium 2-head G450 video card
2.do text expert install with wolverine CDs
3.watch install autodetect "G400", then watch X configuration totally hang
later
	

Actual Results:  Total system hang.

Expected Results:  If correct device drivers had been picked, presumably a
smooth Xwindowing.

    It should be easy (technically -- I know nothing about licensing/legal
issues) to get up-to-date device drivers from:

http://www.matrox.com/mga/support/drivers/latest/home.cfm
Comment 1 Bill Nottingham 2001-02-26 08:08:41 EST
The Matrox dual-head drivers include a large binary-only component,
we won't ship them. As for identifying it as a G400, it's because
they share the same PCI id.
Comment 2 Glen Foster 2001-02-26 18:56:42 EST
We (Red Hat) should really try to resolve this before next release.
Comment 3 Erich Schwarz 2001-02-27 02:14:24 EST
"The Matrox dual-head drivers include a large binary-only component, we won't
ship them."

OK, I understand not wanting binary-only.  But:

Could Red Hat just please consider including the following source code (not
"binary only")?

       
ftp://ftp.matrox.com/pub/mga/archive/linux/2001/beta_1_01_05/mga-1_01_05beta.tgz

Some documentation for this source code is at:

        ftp://ftp.matrox.com/pub/mga/archive/linux/2001/beta_1_01_05/readme.txt

Thank you.
Comment 4 Preston Brown 2001-02-27 18:38:01 EST
we have G450 working as of today's internal tree, available as rawhide soon.
Comment 5 Glen Foster 2001-03-02 13:04:58 EST
Our installer team-lead thinks we should really fix this before next release.
Comment 6 David Sainty 2001-03-18 17:23:56 EST
See also #26677 for my latest comments on G450 freezes. :-)

Note You need to log in before you can comment on or make changes to this bug.