Bug 29544 - kickstarting an already raided disk fails
kickstarting an already raided disk fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 08:39 EST by Anders Blomdell
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 19:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anders Blomdell 2001-02-26 08:39:24 EST
Trying to do a kickstart installationon an already partitioned disk fails
when trying to use raid. With this info in the kickstart file:

  part / --usepart hda1
  part swap --usepart hda5
  part swap --usepart hdb5
  part raid.11 --usepart hda6 
  part raid.12 --usepart hdb6 
  raid /homeA --level 1 --device md0 raid.11 raid.12

I get the following error:

Traceback (innermost last):
  File "./anaconda", line 329, in ?
    instClass = Kickstart(kickstart, serial)
  File "/usr/lib/anaconda/kickstart.py", line 605, in Kickstart
    ksClass = KickstartBase(file, serial)
  File "/usr/lib/anaconda/kickstart.py", line 566, in __init__
    self.readKickstart(file)
  File "/usr/lib/anaconda/kickstart.py", line 440, in readKickstart
    handlers[args[0]](args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 486, in defineRaid
    self.addRaidEntry(mntPoint, raidDev, level, extra)
  File "/usr/lib/anaconda/installclass.py", line 63, in addRaidEntry
    raise ValueError, "unknown raid device %s" % (device,)
ValueError: unknown raid device raid.11

The reason seems to be that preformatted partitions are not put in the 
self.partitions list, but only in the fstab.



IMHO: the partitioning code is so smart that mere mortals have trouble 
understanding it; perhaps it would be a good idea to simplify it and put the 
optimization burden on the person who writes the kickstart file? As it is 
now, using kickstart and more complex partitioning is almost as burdensome 
as installing windows (lots of retries until one gets a working 
configuration).
Comment 1 Michael Fulbright 2001-02-26 11:34:58 EST
This issue has been resolved in internal CVS. You can work around it by
allocating at least one of your partitions.

To address the second concern, in the future we plan on having a way to dump an
existing installation to floppy in the form of a kickstart file so that you will
have a known good starting point.
Comment 2 Anders Blomdell 2001-03-06 05:11:59 EST
Ok, I would really like to try the rawhide version, but I can't find the 

RedHat/instimage anywhere in the rawhide tree! How do I create one myself?



Comment 3 Anders Blomdell 2001-03-08 12:30:01 EST
Above is the statement:
  This issue has been resolved in internal CVS.

But I still get the same error with RawHide from 2000-03-05!!
Comment 4 Michael Fulbright 2001-03-12 12:06:43 EST
I will investigate.
Comment 5 Michael Fulbright 2001-03-12 19:34:12 EST
Ok I think I have this one fixed now in the internal CVS tree. I have used your
ks.cfg sucessfully (and confirmed it did not work originally).

Note You need to log in before you can comment on or make changes to this bug.