This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29550 - Exception during installation of RedHat Linux 7.0 during formating of partitions
Exception during installation of RedHat Linux 7.0 during formating of partitions
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 09:57 EST by Rafael Otalora
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 11:32:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rafael Otalora 2001-02-26 09:57:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)


An exceptional condition has occured. This is most likely a bug. Please copy the full text of this exception and file a bug report at 
http://bugzilla.reghat.com/bugzilla.

Reproducible: Always
Steps to Reproduce:
1. Insert the Redhat 7.0 boot diskette
2. Answered all the installation questions, left the defined partitions of Redhat 6.0 system intact.
3. Requested to format partitions and check bad blocks.
4. Selected packages to install using custom install.
5. Proceed with install.
	

Actual Results:  Get the following error:
An exceptional condition has occured. This is most likely a bug. Please copy the full text of this exception and file a bug report at 
http://bugzilla.reghat.com/bugzilla.

Traceback (innermost.last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc=self.todo.doInstall()
  File "var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.pt", line 1480 in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py, line 46, in systemMounted
    self.loopbackFile=mntPoint+fstab.filesystemSpace(mntPoint)[0][0] + \
  File "var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Expected Results:  Proceed with the installation of packages and selected options.
Comment 1 Michael Fulbright 2001-02-26 11:32:33 EST
Your traceback output appears to be truncated.

Looks alot like bug 18032.
Comment 2 Rafael Otalora 2001-02-27 11:37:01 EST
I have looked at previous bug reports similar to this one. I have changed my installation to indicate not to mount the FAT partitions that exist on the disk, 
by doing this the installer continues with no problems, therefore is the mounting of FAT partitions that causes the installer to crash.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.