Bug 295501 - RFE: Add EDAC driver for Intel 3000/3010 chipsets
RFE: Add EDAC driver for Intel 3000/3010 chipsets
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Aristeu Rozanski
Martin Jenner
:
Depends On:
Blocks: RHEL5u2_relnotes 425461
  Show dependency treegraph
 
Reported: 2007-09-18 17:13 EDT by Jordan Russell
Modified: 2008-05-21 10:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test patch (14.85 KB, patch)
2007-11-02 10:57 EDT, Aristeu Rozanski
no flags Details | Diff
updated patch (14.84 KB, patch)
2007-11-19 11:07 EST, Aristeu Rozanski
no flags Details | Diff

  None (edit)
Description Jordan Russell 2007-09-18 17:13:44 EDT
2.6.23-rc* adds an EDAC driver for Intel's 3000 and 3010 chipsets
(CONFIG_EDAC_I3000).

Any plans to backport it to RHEL5?
Comment 1 RHEL Product and Program Management 2007-11-01 19:25:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Aristeu Rozanski 2007-11-02 10:57:31 EDT
Created attachment 246791 [details]
test patch
Comment 3 Aristeu Rozanski 2007-11-09 14:59:20 EST
Jordan,
can you please test one of these kernels and tell me how it goes?
http://people.redhat.com/arozansk/i3000/kernel-2.6.18-53.el5.i3000.i686.rpm
http://people.redhat.com/arozansk/i3000/kernel-2.6.18-53.el5.i3000.x86_64.rpm

Thanks
Comment 4 Jordan Russell 2007-11-09 15:45:28 EST
I tried kernel-2.6.18-53.el5.i3000.x86_64.rpm, and it doesn't appear that any
new EDAC driver was added (?):

# ls /lib/modules/2.6.18-53.el5.i3000/kernel/drivers/edac/
e752x_edac.ko  edac_mc.ko  k8_edac.ko

# grep EDAC /boot/config-2.6.18-53.el5.i3000
CONFIG_EDAC=y
CONFIG_EDAC_MM_EDAC=m
CONFIG_EDAC_E752X=m
CONFIG_EDAC_K8=m
CONFIG_EDAC_POLL=y

# dmesg | grep -i edac
Comment 5 Aristeu Rozanski 2007-11-09 16:00:07 EST
gah, my mistake, sorry.
I'm building a new one.
Comment 6 Aristeu Rozanski 2007-11-12 16:37:53 EST
Jordan, I just uploaded the new kernel packages, same link.
Comment 7 Jordan Russell 2007-11-13 11:33:16 EST
The new package has the same problem. :)
Comment 8 Aristeu Rozanski 2007-11-13 12:06:27 EST
hm
just checked. it's there:
aris@john:/tmp/t/t$ grep I3000 boot/config-2.6.18-53.el5.i3000 
CONFIG_EDAC_I3000=m

check if you are using the right one:
d7878a443640b923e3e67fa6fda532df  kernel-2.6.18-53.el5.i3000.i686.rpm
fc3211b72367280393964d0b27ef8826  kernel-2.6.18-53.el5.i3000.x86_64.rpm
Comment 9 Aristeu Rozanski 2007-11-13 12:08:22 EST
oh, I see, the x86_64 version is missing the module
duh
Comment 10 Aristeu Rozanski 2007-11-13 12:21:08 EST
hm, it's not supported on 64bits, that's why:
+       depends on EDAC_MM_EDAC && PCI && X86_32
I'll investigate why
Comment 11 Aristeu Rozanski 2007-11-15 12:20:32 EST
There's a patch sent to bluesmoke-devel to remove this limitation but Doug
Thompson still didn't pulled it. I'm building new packages with this issue fixed.
Comment 13 Jordan Russell 2007-11-18 14:11:06 EST
Excellent, that one appears to work (module loaded,
/sys/devices/system/edac/mc/mc0 populated).

Can I expect the driver to be included in future kernel updates for RHEL 5.1, or
will I have to wait until 5.2?
Comment 14 Aristeu Rozanski 2007-11-19 11:02:39 EST
Because it's not a bug fix, I think you'll have to wait for 5.2. If you need it
before, you can request a hotfix creating a ticket on Issue Tracker.
Comment 15 Aristeu Rozanski 2007-11-19 11:07:19 EST
Created attachment 263601 [details]
updated patch

This patch enables the build for x86_64
Comment 17 Don Zickus 2008-01-08 15:46:39 EST
in 2.6.18-64.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 19 Don Domingo 2008-02-07 00:03:36 EST
added to RHEL5.2 release notes under "Kernel-Related Updates":

<quote>
(x86_64) Intel 3000 and 3010 chipsets are now supported through the EDAC driver.
</quote>

please advise if any further revisions are required. thanks!
Comment 20 Don Domingo 2008-04-01 22:11:24 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 21 Don Domingo 2008-04-02 22:53:04 EDT
added note to x86 release notes as well (as per arozanski@redhat.com).
Comment 23 errata-xmlrpc 2008-05-21 10:55:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.