Bug 29553 - (G200/G400)DPMS doesn't work
(G200/G400)DPMS doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 10:04 EST by Chris Ricker
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 02:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 Log (21.83 KB, text/plain)
2001-03-18 12:28 EST, Chris Ricker
no flags Details
XF86Config-4 (1.67 KB, text/plain)
2001-03-18 12:29 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2001-02-26 10:04:30 EST
Just noticed this with wolverine, so Idon't know if it applies to earlier
builds of XFree86 4 as well, but DPMS doesn't work.  One system I've tried
is a Matrox g200 + AOC Spectrum 7Glr, and the other is a Matrox g400 max +
NEC C500.  On both, DPMS is enabled:

DPMS (Energy Star):
  Standby: 600    Suspend: 1200    Off: 1800
  DPMS is Enabled
  Monitor is On


but the monitors never go to Suspend or Off.  DPMS did work on both systems
with XFree86 3.3.6
Comment 1 Mike A. Harris 2001-03-01 21:15:04 EST
Can you provide a copy of your X server logs and your config files please?
Comment 2 Chris Ricker 2001-03-18 12:28:24 EST
Created attachment 12905 [details]
XFree86 Log
Comment 3 Chris Ricker 2001-03-18 12:29:14 EST
Created attachment 12906 [details]
XF86Config-4
Comment 4 Chris Ricker 2001-03-18 12:30:11 EST
The files are attached.  The machine is now running qa0309.
Comment 5 Chris Ricker 2001-03-23 09:09:40 EST
This is still true with qa0322
Comment 6 hjl 2001-03-26 12:19:17 EST
I got the same problem. I have a G200 and Optiquest V95.
DPMS works in gdm.

I tried to enable/disable power management in screen saver
config in GNOME. It makes no differences.
Comment 7 Bill Nottingham 2001-04-23 01:00:41 EDT
Assigning to xscreensaver, although the fix will have to be in both
xscreensaver & control-center. More later.
Comment 8 Chris Ricker 2001-04-23 01:05:37 EDT
This bug has nothing to do with either xscreensaver or control-center.  I'm
running blackbox without gnome or xscreensaver.

In RH 7.1, dpms is now working with the G400 but not the G200.
Comment 9 Bill Nottingham 2001-04-23 01:10:22 EDT
OK then, nevermind. :)
Comment 10 Mike A. Harris 2001-06-14 23:12:42 EDT
DPMS *works* on both cards for me.  You need to configure DPMS as per
the XF86Config manpage.  There are 3 different timer settings that
must be placed in the ServerFlags section.

If you prefer to use a GUI tool to set this stuff up, both xscreensaver
and control-center are buggy.  Your config file does not contain
the necessary DPMS settings.
Comment 11 Chris Ricker 2001-06-15 09:33:25 EDT
No.  The three timers you're talking about (BTW, there are actually 4: 
BlankTime, StandbyTime, SuspendTime, and OffTime) do NOT have to be explicitly
defined in XF86Config for DPMS to work.  Try it and see -- if you remove them
from your XF86Config, you'll find that X just uses the default values
(10:20:30:40 minutes), which you can verify using "xset -q".  You can configure
them at run-time using "xset -s"....  The only statement in XF86Config required
for DPMS is Option "dpms" within the monitor section.  I've tried it with and
without the timers in XF86Config and it just doesn't work.
Comment 12 Mike A. Harris 2002-07-22 02:51:37 EDT
Since I last tried this and had it working, I haven't tried again.
Do you still observe this problem in RHL 7.3 with XFree86 4.2.0, or
even the Limbo beta release?

Just inquiring if the issue is still seen before trying to reproduce
personally again in current release.
Comment 13 hjl 2002-07-22 11:29:42 EDT
7.3 seems to work fine.

Note You need to log in before you can comment on or make changes to this bug.