Bug 29562 - noise in the sound output on YMF PCI 754 on Toshiba 2805
noise in the sound output on YMF PCI 754 on Toshiba 2805
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 11:17 EST by Florin Iucha
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 14:03:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kill volume of P44Slot (1.04 KB, patch)
2001-04-19 13:57 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Florin Iucha 2001-02-26 11:17:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (WinNT; U)


The sound is not autodetected by the installer.
If I modprobe ymfpci I get a noise in the speakers. rmmod ymfpci reduces the noise but it's still there.
The noise is affected only by master volume and pcm volume.

Reproducible: Always
Steps to Reproduce:
1. modprobe ymfpci
2.
3.
	

Actual Results:  Noise in the speakers. The music can barely be heard.

Expected Results:  Clear sound.

Using the ymfpci module from the alsa package fixed the problem. I have used alsa-0.9.0beta.
Comment 1 Bill Nottingham 2001-02-26 11:21:54 EST
Assigning to kernel.
Comment 2 Pete Zaitcev 2001-02-26 14:18:23 EST
I worked with Florin before, he is willing to test patches.
However, I am running out of ideas. We know that it is not
a chip's internal loopback, and it seems that it is not the
legacy block. So, the native PCI block produces these noises.

The bug is easy to reproduce on Toshibas, for example Jacob
Berkman from Ximian and Jeff Garzik hit it too. If _anyone_
has a failing Toshiba with YMF in Bay Area and is willing to
help, please contact me.

My home VAIO works just fine, of course...

The current plan is to see what the latest ALSA may offer.

-- Pete
Comment 3 Pete Zaitcev 2001-04-09 00:02:43 EDT
Tried ALSA's diffs, fixed a bug with microcode loading,
but still buzzes! What an evil lot.

I think I will not be able to fix this for the release date.
Sorry.
Comment 4 Pete Zaitcev 2001-04-19 13:57:55 EDT
Created attachment 15789 [details]
Kill volume of P44Slot
Comment 5 Pete Zaitcev 2001-04-19 14:03:22 EDT
I talked to several people, including Nick Brown @coe.int,
Jeff Garzik, and others. We figured that the buzzing
is produced by the P44Slot on "-E" microcode (it reports
non-zero work area size). The easy fix is to mute the
P44Slot channel, per attachement.

I am concerned by our discovery, because
 1. Firmware expends resources to create the buzzing,
    perhaps affecting other channels.
 2. In all probability, the chip hits work area all the time
    and eats PCI bandwidth
 3. There is something about it that we do not understand.

Note You need to log in before you can comment on or make changes to this bug.