Bug 29566 - Hard drive kickstart does not work
Hard drive kickstart does not work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 11:43 EST by Bryan Leopard
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 11:43:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-02-26 11:43:14 EST
Kick start fails when source files are copied to a hard drive because of 
duplicate 8.3 file names.

To reproduce, copy all files from CD #1 and CD #2 to a bootable, 2GB DOS 
C: drive.  Edit AUTOEXEC.BAT to have loadlin launch a kickstart install 
from \AUTOBOOT; kickstart file is on the C: drive.  Reboot to start the 
installation.

Installation proceeds normally until installer begins reading the package 
files.  The installer will fail with a 'package not found', 'corrupt 
package' or similar message, depending on the order in which you copied 
the distribution files to C:.


There is a work-around:

1. Copy the contents of CD #1 to C:2. Copy the contents of CD #2 to a 
(newly created) \TEMP directory on C:
3. Identify file names in \TEMP\RedHat\RPMS that match \RedHat\RPMS.
4. Rename the duplicate files in \TEMP\RedHat\RPMS to new, unused names 
and alter \TEMP\RedHat\RPMS\TRANS.TBL to match.
5. Cat \TEMP\RedHat\RPMS\TRANS.TBL to the end of \RedHat\RPMS\TRANS.TBL
6. Move \TEMP\RedHat\RPMS\*.* to \RedHat\RPMS
7. The kickstart will now work.
Comment 1 Glen Foster 2001-02-26 18:20:07 EST
We only support long (ext2 or vfat) filenames
Comment 2 Matt Wilson 2001-02-28 10:20:20 EST
I need a full traceback -- if you are using kickstart you can still use each rpm
file.

Note You need to log in before you can comment on or make changes to this bug.