Bug 29567 - Install loader cannot mount ida device
Install loader cannot mount ida device
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 11:46 EST by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 18:53:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-02-26 11:46:24 EST
Scenario:

Kickstart from a hard drive, using a Compaq array controller as primary 
boot device. (module cpqarray).

Distribution files are in partition ida/c0d0p4.

Launch the install from the FAT partition using loadlin .  Loadlin command-
line includes: ks=hd:ida/c0d0p4/ks.cfg


Result:

Loader fails because it cannot find ks.cfg.


Observations:

The log panel indicates the loader attempted to create device 'ida' 
instead of 'ida/c0d0p4'.  The error message is: 'failed to make device 
ida'.


Notes:

No fix provided will work until the auto-probe of the array controller is 
also fixed (7.1 RC1 does not automatically pick up cpqarray during 
autoprobe).  This has been tested with 7.0 (no broken autoprobe) and fails 
in a similar manner.
Comment 1 Glen Foster 2001-02-26 18:55:13 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Matt Wilson 2001-02-28 10:26:53 EST

*** This bug has been marked as a duplicate of 23942 ***
Comment 3 Matt Wilson 2001-03-07 10:57:31 EST
not really a dup of 23942;  I have a fix checked in to CVS and will test later
today.
Comment 4 Matt Wilson 2001-03-08 12:00:37 EST
verified - I kicked off a ks.cfg on ida/c0d0p7 in the test lab today.
Comment 5 Bryan Leopard 2001-03-15 18:36:23 EST
We ran a test yesterday evening.  It got further, but still dies.
Heres what we found:

Here is the error message that dumps to the screen with
an array controller (tested unit was ML 330, SA 4200) using
qa0309 pass from RedHat.  SCSI controller works ok.
_______________________________________________________
Traceback (innermost last):
File /usr/bin/anaconda.real, line 449, in ?
i = string.index(driveAndType, :)

File /usr/lib/python1.5/site-packages/string.py, line 226, in index
ValueError: substring not found in string.index

install exited abnormally
<termination signals to screen>
Comment 6 Matt Wilson 2001-03-15 18:53:04 EST
what were you testing against?  i've already fixed this bug.
Comment 7 Matt Wilson 2001-03-15 19:19:38 EST
oh, qa0309 - my fix wasn't in that test tree.

Note You need to log in before you can comment on or make changes to this bug.