Bug 29572 - [aic7xxx] kernel hangs loading scsi driver
[aic7xxx] kernel hangs loading scsi driver
Status: CLOSED DUPLICATE of bug 29555
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 12:38 EST by Steve Dum
Modified: 2007-04-18 12:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 13:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2001-02-26 12:38:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (X11; I; Linux 2.2.5-15smp i686)


Install hangs loading the aic7xxx driver.
after loading the driver, it prints messages like
    <4> scsi : aborting command due to timeout : pid 0 scsi -, channel 0,
id 10, lun 0 0x 12 00 00 00 ff 00
Message is repeated twice for each scsi id,and at least twice thru the list
of id's with
about a 3 second timeout between messages.  Once its done with this it does
actually print summary of finding the disk drives present.  It then loops
with messages of
the form
    bus is being reset for host 0 channel 0
host 0 channel 0 reset lun 0 timed out - trying harder.
Message is repeated at about 3 second intervals 

Hardware is SGI 1200   This failure did not occur in the fisher beta.
The following log messages (from fisher beta) may help identify card
causing problem
scsi 0:
<Adaptec aic7896/97 Ultra2 SCSI adapter
aic7896/97: Wide Channel A, SCSI Id=7, 32/255 SCBs
scsi 1:
<Adaptec aic7896/97 Ultra2 SCSI adapter>
aic7896/97: Wide Channel B, SCSI Id=7, 32/255 SCBs



Reproducible: Always
Steps to Reproduce:
1. Insert wolverine CD 1
2. attempt to boot system
3.  hit return at lilo prompt.
	

Actual Results:  system loops loading aic7xxx 

Expected Results:  no timeouts.
Comment 1 Michael K. Johnson 2001-02-26 15:01:27 EST
Doug, is this the configuration bug, or something else?
Comment 2 Doug Ledford 2001-02-26 15:11:47 EST
Different issue.  I need to know what disks are in the system to be able to help
with this.
Comment 3 Glen Foster 2001-02-26 18:57:07 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 Steve Dum 2001-02-26 19:52:41 EST
I'm not sure what you want - the Scsi adapter doesn't seem to be
as clear about identifing the drivers as the ide does.
There are two disks, both the same:
Disk /dev/sda: 255 heads, 63 sectors, 2231 cylinders
The messages from a 7.0 boot are as follows:
Feb 23 13:48:54 maalox kernel: SCSI subsystem driver Revision: 1.00
Feb 23 13:48:55 maalox kernel: kmod: failed to exec /sbin/modprobe -s -k
scsi_hostadapter, errno = 2
Feb 23 13:48:55 maalox kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA
DRIVER, Rev 6.0.8 BETA
Feb 23 13:48:55 maalox kernel:         <Adaptec aic7896/97 Ultra2 SCSI adapter>
Feb 23 13:48:55 maalox kernel:         aic7896/97: Wide Channel A, SCSI Id=7,
32/255 SCBs
Feb 23 13:48:55 maalox kernel:
 
Feb 23 13:48:55 maalox kernel:         <Adaptec aic7896/97 Ultra2 SCSI adapter>
Feb 23 13:48:55 maalox kernel:         aic7896/97: Wide Channel B, SCSI Id=7,
32/255 SCBs
Feb 23 13:48:55 maalox kernel:
Feb 23 13:48:55 maalox kernel:   Vendor: IBM       Model: DNES-318350Y      Rev:
SAA0
Feb 23 13:48:55 maalox kernel:   Type:   Direct-Access                      ANSI
SCSI revision: 03
Feb 23 13:48:56 maalox kernel:   Vendor: SGI1200   Model: Server Family     Rev:
1.01
Feb 23 13:48:56 maalox kernel:   Type:   Processor                          ANSI
SCSI revision: 02
Feb 23 13:48:56 maalox kernel: (scsi0:A:1): async, 8bit
Feb 23 13:48:56 maalox kernel: scsi0:0:1:0: Tagged Queuing enabled.  Depth 254
Feb 23 13:48:56 maalox xfs: xfs startup succeeded
Feb 23 13:48:56 maalox kernel: (scsi0:A:2): async, 8bit
Feb 23 13:48:56 maalox xfs: listening on port 7100
Feb 23 13:48:56 maalox kernel: scsi0:0:2:0: Tagged Queuing enabled.  Depth 254
Feb 23 13:48:56 maalox kernel: Attached scsi disk sda at scsi0, channel 0, id 1,
lun 0
Feb 23 13:48:56 maalox anacron: anacron startup succeeded
Feb 23 13:48:56 maalox kernel: Attached scsi disk sdb at scsi0, channel 0, id 2,
lun 0
Feb 23 13:48:57 maalox kernel: (scsi0:A:1): async, 16bit
Feb 23 13:48:57 maalox kernel: (scsi0:A:1): synchronous at 40.0MHz, offset 0x1f,
16bit

Comment 5 Steve Dum 2001-02-27 12:08:47 EST
One correction for that last message - I believe the /var/log/messages text is
from a fisher boot,
not 7.0
Comment 6 Michael K. Johnson 2001-02-28 23:46:58 EST
Since fisher and wolverine have completely different aic7xxx drivers,
it might matter which log we see.  :-)

Is this SMP?

If so, please try booting "noapic" and see if that works around the
problem.
Comment 7 Mike Sklar 2001-03-01 20:16:24 EST
I tried to kickstart passing the noapic option to the kernel on my valinux 2200
(dual 850MHz/512MB mem/LVD HD) with no luck. I still hang at the "Loading
aic7xxx driver...".
Comment 8 Steve Dum 2001-03-02 14:37:46 EST
I cant provide wolverine log, since it hangs in the boot process.  I guess one
might
be able to video record the screen but that's not a readily available tool.

It is a 2 processor machine and booting 'linux noapic' in response to the
install lilo boot prompt
makes no difference in behavior.
Comment 9 Mike Sklar 2001-03-09 18:18:03 EST
I grabbed a bootnet.img from rawhide today (3/9/01) the bootnet.img is dated
3/5/01. I dd'd it to a floppy and copied over my usual beowulf kickstart stuff.
Wolverine kickstarted just fine with this new image. I am using a dual 850MHz
VALinux 2200 (2u) with 2GB memory per machine.
Comment 10 Dana Canfield 2001-04-17 13:01:54 EDT
Just thought I'd mention that I am experiencing this problem as well on a VA
2240 box.  Hangs at the Loading AIC-7xxx driver screen and in the other screens
I find info about timeouts as described in the other comments.  I've tried
booting from both a seawolf CD and a floppy.  This machine still boots fine from
a 7.0 boot CD.
Comment 11 Dana Canfield 2001-04-17 13:17:31 EDT
More detail about the error I'm seeing in the background... the exact messages are:
<4>scsi : aborting command due to timeout: pid 0, scsi x, channel 0, id xx, lun
0 0x12 00 00 00 ff 00

I get two of these for scsi 0 on every id 00-15 (except 7), and then again for
scsi 1.

I have no SCSI devices attached to these controllers (7896, I believe,
integrated on the motherboard), but there is a mylex RAID card.

I also just tried a rawhide boot floppy from March 14th that said RedHat 7.0.91
and received the same results.

Hope this helps.
Comment 12 Doug Ledford 2001-04-19 19:57:35 EDT

*** This bug has been marked as a duplicate of 29555 ***

Note You need to log in before you can comment on or make changes to this bug.