Bug 29573 - erroneous IRQ conflict message
erroneous IRQ conflict message
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 12:49 EST by Ed Ewing
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 12:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linux-sema.patch (1001 bytes, patch)
2001-02-28 12:04 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Ed Ewing 2001-02-26 12:49:06 EST
When lpd starts it scans all ports and then reports irq conflict. Have
added irq=none to modules.conf with no change on startup. Fisher beta did
not have this problem although lpd didn't start on boot.

One other note: there is no installed /proc/parport directory.

Thanks
Comment 1 Glen Foster 2001-02-26 18:22:57 EST
This looks more like a kernel issue rather than an LPRng issue.
Comment 2 Tim Waugh 2001-02-27 10:13:59 EST
Yes, the message is incorrect and should be ignored.
/proc/parport has moved to /proc/sys/dev/parport, and the ports have names
'parport0', 'parport1', instead of '0', '1', etc.
Comment 3 Ed Ewing 2001-02-27 10:30:56 EST
I would like to ignore the error message but printing a simple page takes 
anywhere from 1 to 2 minutes
Comment 4 Tim Waugh 2001-02-27 10:34:20 EST
If you print a page of text by printing directly to the port, is that slow too?

cat textfile > /dev/lp0

Also, is it consistently slow, or does print normally and then stall?
Comment 5 Tim Waugh 2001-02-27 10:36:27 EST
See also bug #26996, which might or might not be what you're seeing.
Comment 6 Ed Ewing 2001-02-28 10:54:25 EST
cat textfile > /dev/lp0 produces the same result. Have looked at Bug 26996 which 
appears to have a similar stalling problem except this printer stalls from the 
get go. Appears that much troubleshooting has occurred on 26996 with no solution 
yet.
Will try other options if requested.
Comment 7 Tim Waugh 2001-02-28 12:03:33 EST
Please try this patch, which I think is the resolution for bug 26996.
Comment 8 Tim Waugh 2001-02-28 12:04:15 EST
Created attachment 11360 [details]
linux-sema.patch
Comment 9 Tim Waugh 2001-03-09 12:58:25 EST
Ed, are you still getting slow printing?
Comment 10 Ed Ewing 2001-03-10 10:59:33 EST
Yes, because I was unable to successfully apply the linux-sema.patch and 
rebuild the kernel.
Comment 11 Tim Waugh 2001-03-11 06:11:19 EST
Could you try a newer kernel?  -0.1.19 is in rawhide now.
Comment 12 Ed Ewing 2001-03-12 11:12:25 EST
Printing is working using the -0.1.19 kernel!
Some other possibly irrelevent info:
1. Still receive the irq error message on boot.
2. Installed -i the -0.1.19 kernel and -U the headers.
3. Had to hand edit lilo.conf to add -0.1.19.

Thanks for your help.
Comment 13 Tim Waugh 2001-03-12 17:11:33 EST
Okay, great.  I've made a patch to get rid of the warning message since it's 
triggered by unreliable information, and it's in my queue to send to Linus.
Comment 14 Arjan van de Ven 2001-03-21 13:08:07 EST
I assume this patch is in our latest kernels and will close this bug.
Comment 15 Tim Waugh 2001-03-21 13:35:38 EST
It isn't, although I've sent it to Linus twice now.
Comment 16 Tim Waugh 2001-04-06 12:36:03 EDT
FWIW, this cosmetic bug is fixed in 2.4.3.

Note You need to log in before you can comment on or make changes to this bug.