Bug 295851 - Enable autohinting for Indic fonts
Summary: Enable autohinting for Indic fonts
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig   
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-19 06:31 UTC by Rahul Bhalerao
Modified: 2009-09-21 19:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 16:05:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for enabling autohinting for indic and sinhalese scripts (2.31 KB, patch)
2007-10-19 11:12 UTC, Rahul Bhalerao
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 15822 None None None Never

Description Rahul Bhalerao 2007-09-19 06:31:25 UTC
Description of problem:

Autohinting for Indic fonts has been disabled since freetype could not handle it
properly. But since freetype-2.3.5, the hinting problems for indic fonts have
been fixed. Thus this is a request to enable the autohinting in fontconfig again
for all the indic fonts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start any desktop application in any of the indic language
2. Open the font preferences dialog from the main menu and click the 'Details'
button on it 
3. Try changing value for the hinting from none to full. 
  
Actual results:
No changes seen for the indic fonts display. They look slightly blur all the time.

Expected results:
At smaller size, the smoothening effect on the fonts should be reduced to avoid
the blurriness and enhance the readability. 
On changing the value for hinting to Full, the fonts should appear more sharp,
clear and readable even for the complex shaped glyphs in indic fonts.

Additional info:
This may be enabled in the config files located in /etc/fonts/conf.d/ directory

Comment 1 Rahul Bhalerao 2007-10-19 11:12:22 UTC
Created attachment 232421 [details]
Patch for enabling autohinting for indic and sinhalese scripts

Comment 2 Jens Petersen 2007-10-22 00:09:25 UTC
or should we just remove Indic lines completely?

Comment 3 Rahul Bhalerao 2007-10-22 05:45:51 UTC
I thought so, but just not sure if that will change the current default
configuration. 

Comment 5 Behdad Esfahbod 2008-05-05 01:04:10 UTC
Filed upstream:
http://bugs.freedesktop.org/show_bug.cgi?id=15822


Comment 6 Behdad Esfahbod 2008-05-05 16:05:20 UTC
Committed upstream.  Will be in next fontconfig release that I will then put in
rawhide and F9.


Note You need to log in before you can comment on or make changes to this bug.