Bug 29588 - Graphic Installer crash with r128
Graphic Installer crash with r128
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-26 14:03 EST by LENHOF
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-05 11:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description LENHOF 2001-02-26 14:03:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.8)

When launching the install graphically... the installed failed

Reproducible: Always
Steps to Reproduce:
1.Insert CDROM
2.Press Enter

Actual Results:  Reproduced by hand :

Running anaconda - please wait...
Probing for mouse type...
Waiting for X server to start... log located in /tmp/X.log
.. X server started successfully
Gdk-ERROR **: Fatal IO error 104 (Connection reset by peer) on X server :1
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems.../proc/bus/usb

Expected Results:  Launching graphical install

tried also with lowres...with vga=773, vga=775,... 

Works great in text mode install

The same install worked with Fisher and Guinness
Comment 1 LENHOF 2001-02-27 03:34:59 EST
I have exactly the same problem with a laptop at work :
Dell Latitude CPx J650GT
with ATI M1 8Mo
ESS Maestro3

Comment 2 Mike A. Harris 2001-03-01 15:35:11 EST
I think this is related to the busmastering issue on Dell laptops.
Enabling busmastering with 'setpci' fixes this if I'm correct, however
the commands are cryptic.. lemme see if I can find them..

Taken from bug #29966 - try this before running XFree..
Let me know if it fixes the problem.

dev=01:00.0   # change as appropriate
echo Enabling bus mastering on device $dev
setpci -s $dev 4.w=$(printf %x $((0x$(setpci -s $dev 4.w)|4)))
echo Enabling bus mastering on host bridge $dev
setpci -s $dev 4.w=$(printf %x $((0x$(setpci -s $dev 4.w)|4)))

Comment 3 LENHOF 2001-03-01 17:08:33 EST

That will not correct the problem... because I can run Guinness, Fisher,
Wolverine on this laptop... But I can only install graphically it with Guinness
or Fisher... and I install it in text mode for Wolverine... 

But after the installation I could run Xfree without any kind of problem 
(I just save my XF86Config-4 on a floppy because If I remember well the
XFConfigurator does'nt recognize very well my screen (Hor 30-60....and so on))

I just precise this problem is during the install only....

I you want I could make some try at home if you put some new files on an ftp...
for my personnal desktop... and after It will work i will try again with the laptop.

Comment 4 Glen Foster 2001-03-02 13:06:16 EST
Our installer team-lead thinks we should really fix this before next release.
Comment 5 Preston Brown 2001-03-05 00:44:30 EST
I will test on my Dell laptop tomorrow.
Comment 6 Trond Eivind Glomsrxd 2001-03-05 11:01:24 EST
Hmm... could this be related to the recent kernel fix for R128?
Comment 7 Bill Nottingham 2001-03-05 11:03:15 EST
No. The installer doesn't use DRI.
Comment 8 Trond Eivind Glomsrxd 2001-03-05 15:19:48 EST
The first bug works here now (r128)... for the second issue (laptop), please
open a separate bug.

Note You need to log in before you can comment on or make changes to this bug.