This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 29594 - rpmbuild -ba vim.spec fails
rpmbuild -ba vim.spec fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 15:13 EST by David Lawrence
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 18:55:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2001-02-26 15:13:18 EST
trying to rebuild the vim source RPM fails as follows:
+ perl -pi -e s,bin/nawk,bin/awk,g runtime/tools/mve.awk
Can't open perl script "-e": No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.28446 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.28446 (%prep)
[root@test90 /root]#
Comment 1 Glen Foster 2001-02-26 18:34:46 EST
Is this a full-install system?  If so, there's a problem.  Please describe the
install you have on the system (full, workstation, server, something else).
Comment 2 Glen Foster 2001-02-26 18:55:21 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Trond Eivind Glomsrxd 2001-02-26 21:44:39 EST
perl should (and does) interpret "-e" as "evaluate string", I can't see how
it can complain about it not finding the file.

Anyway, I just rebuilt without problems, so this is not a bug. You didn't use a
bad kernel? (2.4.1-0.1.12 and 13 are very bad, 14 a bit better) This causes lots
of programs (pthreads-linked) to randomly bug out.

Note You need to log in before you can comment on or make changes to this bug.