Bug 295981 - Segfault while getting room list
Segfault while getting room list
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmoto (Show other bugs)
7
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 04:50 EDT by Lutz Lange
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: 0.3.3-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 16:02:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of xmoto segfault (1.86 MB, application/text)
2007-09-20 05:18 EDT, Lutz Lange
no flags Details

  None (edit)
Description Lutz Lange 2007-09-19 04:50:34 EDT
Description of problem:
xmoto ends with segfault while getting room list

Version-Release number of selected component (if applicable): 0.3.3-1.fc7.i386


How reproducible:

Steps to Reproduce:
1. start xmoto
2. select options -> www -> rooms -> get list
  
Actual results:
Segfault

Expected results:
internet room list
Comment 1 Jon Ciesla 2007-09-19 08:32:40 EDT
Can you try running xmoto from the command line and pasting the output here?
Comment 2 Lutz Lange 2007-09-20 05:18:50 EDT
Created attachment 200571 [details]
strace of xmoto segfault
Comment 3 Lutz Lange 2007-09-20 05:20:38 EDT
i did run xmoto from command line. Only output was Segmentation fault.
I tried with using -d switch -> same result.

Only thing i could think of was an strace of the situation.
i hope that helps.
Comment 4 Jon Ciesla 2007-09-24 07:44:52 EDT
I was able to reproduce the problem, but not figure out a solution yet.  I have
sent the problem upstream, as I see no mention of it on their forums.  I'll keep
poking around at it until they get back to me.  Thank you!
Comment 5 Jon Ciesla 2007-09-24 12:12:25 EDT
Word from upstream is it's fixed in svn.  Working on release with that content.
 Will push ASAP.
Comment 6 Jon Ciesla 2007-09-24 14:54:50 EDT
Build 0.3.3-2 in rawhide, with patches.  Please test.  I will also, when I can.
 If you can confirm it works before I do, I'll build and push for f-7.

http://koji.fedoraproject.org/koji/buildinfo?buildID=19417
Comment 7 Jon Ciesla 2007-09-25 07:27:50 EDT
I tested, it works.  Built for F-7 and requested a push to stable.
Comment 8 Fedora Update System 2007-09-26 16:02:32 EDT
xmoto-0.3.3-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.