Bug 2960 - linuxconf segfaults on /etc/named.conf
linuxconf segfaults on /etc/named.conf
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 4297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-21 19:40 EDT by eric_seppanen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-28 16:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric_seppanen 1999-05-21 19:40:00 EDT
Linuxconf was segfaulting every time I ran it- at first
right away, then only when I tried to run the
server-tasks:domain-name-server menu item.  Removing
/usr/lib/linuxconf/modules/dnsconf.so.1.14.4 fixed the
problem temporarily.  Removing "statistics-interval" and
"cleaning-interval" lines from named.conf fixed it
permanently.

Example named.conf that shows this problem:

options {
	directory "/var/named";
        statistics-interval 0;
        cleaning-interval 1440;
};

zone "." {
	type hint;
	file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
	type master;
	file "named.local";
};
Comment 1 Harry Hart 1999-07-08 20:11:59 EDT
I ran in to this bug, too.  It happens when etc/named.conf is using
the old (BIND v4) syntax.  It stopped when I changed etc/named.conf to
use the new (BIND v8) syntax.  Perhaps dnsconf should complain about
old-style syntax, rather than seg faulting.... ?
- hh
Comment 2 eric_seppanen 1999-07-09 13:08:59 EDT
I should note that "statistics-interval" and "cleaning-interval" are
valid bind 8 syntax, and the example I give is a legal bind 8
named.conf.  The directives that choke linuxconf aren't necessary but
I like them because it reduces logfile clutter.  Segfaulting on legal
directives is dumb.  I don't think this is Red Hat's problem, but I
posted the bug in the hope the workaround would prove useful to
others.
Comment 3 rodsmith 1999-07-31 23:53:59 EDT
I just ran into something that may be related.  My named.conf doesnt'
have any references to statistics-interval or cleaning-interval, but I
got segfaults until I renamed named.conf to foo, then they went away.
When I renamed foo back to named.conf, linuxconf continued to work.
I'd been using the same named.conf for several days without problems
(I installed BIND just recently, actually).
Comment 4 Derek Tattersall 1999-08-03 15:24:59 EDT
*** Bug 4297 has been marked as a duplicate of this bug. ***

After manualy configuring bind, and changing other /etc
files, such as resolve.conf, when linuxconf is run it core
dumps.  When the line
module.list 1 dnsconf

was removed from /etc/conf.linuxconf, it stopped (until a
the next reboot when the line was added.  That shits me:( )
Comment 5 eric_seppanen 1999-08-10 19:18:59 EDT
This bug is fixed, for me anyway, by the new Linuxconf RPM listed in
the errata page:
linuxconf-1.16r1.3-1.i386.rpm

Thanks, guys.
Comment 6 Michael K. Johnson 1999-08-28 16:17:59 EDT
Thanks for the verification that it is fixed!

Note You need to log in before you can comment on or make changes to this bug.