Bug 2963 - Feature request: XFree86-doc as ascii
Feature request: XFree86-doc as ascii
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
All Linux
medium Severity low
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-22 08:30 EDT by ak
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-08 12:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ak 1999-05-22 08:30:32 EDT
It is very cool that RedHat finally ships the X11
documentation in XFree86-doc. Thanks :)

But unfortunately it is shipped in .ps, which makes it waste
a lot of disk space and is hard to grep. With a small
Makefile tweak (sorry no patch because I won't download the
source rpm just for that now) the groff -Tps could be
changed to groff -Tascii and ASCII versions of the
documentation could be generated. I would only ship the
.txt versions to save disk space. If you really think
.ps is still needed a .pdf version may be more appropiate
(via ghostscript ps2pdf, I think requiring gs to rebuild the
srpm is not unreasonable)

This has several advantages:
- It can be linked from some page in the web
browser/gnome-help (I think that would help newbie X11
developers a lot and would lower support load in linux
newsgroups)
- It saves disk space
- It can be searched easily unlike .ps

I think with a minimal change RH could be made more
developer friendly here.
Comment 1 Jay Turner 1999-05-24 15:27:59 EDT
This request has been forwarded to a developer for future releases.
Comment 2 Preston Brown 1999-06-08 12:14:59 EDT
This is currently impossible because the documentation is distributed
as PostScript and FrameMaker source.  We don't have the means to
convert the FrameMaker files to ASCII, so PostScript is the best we
can do.

------- Email Received From  Andi Kleen <ak@muc.de> 06/08/99 14:47 -------

Note You need to log in before you can comment on or make changes to this bug.