Bug 296611 - missing man pages for symlinked commands
missing man pages for symlinked commands
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 13:22 EDT by Todd Zullinger
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 11:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add manpage symlink creation to F-& and devel branch spec files (3.56 KB, patch)
2007-09-19 13:22 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2007-09-19 13:22:35 EDT
Hola Harald,

cdrkit creates symlinks to various binaries from the older cdrtools package that
it replaces.  The package should also provide symlinks (or stub man pages or .so
man pages, etc.) to the man pages so users who only know the commands by their
previous (and far more obvious) names can find help a little easier.

The attached patch adds symlinks for the cdda2wav, cdrecord, dvdrecord, and
readcd man pages to the F-7 and devel branch spec files.  Hopefully I've not
missed any needed links.
Comment 1 Todd Zullinger 2007-09-19 13:22:35 EDT
Created attachment 199821 [details]
patch to add manpage symlink creation to F-& and devel branch spec files
Comment 2 Harald Hoyer 2007-09-20 11:36:29 EDT
switched to alternatives :)
Comment 3 Aaron Konstam 2007-09-25 09:56:54 EDT
This seems to be taking the wrong slant on the problem. The general solution is
to have man detect the symbolic link and follow it to the right man page.
By the way:  /usr/bin/mkisofs -> genisoimage 
is another candidate.

As far as I can figure it out Ubuntu handles it that way. I am sorry but what
you suggest seems like a kludge.
Comment 4 Harald Hoyer 2007-09-25 10:24:12 EDT
These are the symlinks set up by "alternatives" in the new rpm packages:

/etc/alternatives/cdda2wav->/usr/bin/icedax
/etc/alternatives/cdda2wav-cdda2wavman->/usr/share/man/man1/icedax.1.gz
/etc/alternatives/cdrecord->/usr/bin/wodim
/etc/alternatives/cdrecord-cdrecordman->/usr/share/man/man1/wodim.1.gz
/etc/alternatives/cdrecord-dvdrecord->/usr/bin/wodim
/etc/alternatives/cdrecord-dvdrecordman->/usr/share/man/man1/wodim.1.gz
/etc/alternatives/cdrecord-readcd->/usr/bin/readom
/etc/alternatives/cdrecord-readcdman->/usr/share/man/man1/readcd.1.gz
/etc/alternatives/mkisofs->/usr/bin/genisoimage
/etc/alternatives/mkisofs-mkhybrid->/usr/bin/genisoimage
/etc/alternatives/mkisofs-mkisofsman->/usr/share/man/man1/genisoimage.1.gz
/usr/bin/cdda2wav->/etc/alternatives/cdda2wav
/usr/bin/cdrecord->wodim
/usr/bin/dvdrecord->/etc/alternatives/cdrecord-dvdrecord
/usr/bin/mkhybrid->genisoimage
/usr/bin/mkisofs->/etc/alternatives/mkisofs
/usr/share/man/man1/cdda2wav.1.gz->/etc/alternatives/cdda2wav-cdda2wavman
/usr/share/man/man1/cdrecord.1.gz->/etc/alternatives/cdrecord-cdrecordman
/usr/share/man/man1/dvdrecord.1.gz->/etc/alternatives/cdrecord-dvdrecordman
/usr/share/man/man1/mkisofs.1.gz->/etc/alternatives/mkisofs-mkisofsman
Comment 5 Harald Hoyer 2007-09-25 10:25:22 EDT
what is a kludge here?

Note You need to log in before you can comment on or make changes to this bug.