This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 296621 - loop with OPTIONS=last_rule breaks symlink creation for live images
loop with OPTIONS=last_rule breaks symlink creation for live images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-19 13:28 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 16:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-09-19 13:28:15 EDT
Live images want to be able to create some symlinks to loop devices that are
used for the system so that they can later be identified.  We add the udev rules
to do so in the initramfs when we're setting up the loop devices.  But since the
loop config has OPTIONS=last_rule, the symlinks never get created
Comment 1 Harald Hoyer 2007-09-20 05:00:39 EDT
ok, but please do not create 128 loop devices :)
Comment 2 Harald Hoyer 2007-09-20 05:17:34 EDT
oh, and you can always place your rules in 49-myloop.rules
Comment 3 Jeremy Katz 2007-09-20 07:43:24 EDT
(In reply to comment #1)
> ok, but please do not create 128 loop devices :)

We use a number of them during live CD boot...  although I guess since we only
have 8 by default, n+8 isn't that bad.  So probably would just choose 16.  

(In reply to comment #2)
> oh, and you can always place your rules in 49-myloop.rules

Nope -- have to append to an existing file so that SELinux doesn't get in the
way.  No policy is loaded in the initramfs so files get created as unlabeled_t;
reading files labeled unlabeled_t is (rightfully) denied.  We can't set the
context in the initramfs because the kernel won't let you set security xattrs
that it doesn't know about.

Note You need to log in before you can comment on or make changes to this bug.